Open extra topbar

alexg (page 139)

I reply to all queries on the forums and via email, once per day, Monday to Friday (not weekends).

If you are new here, please see some information on how to ask for support. Thank you!

alexg

Forum Replies Created

Viewing 15 posts - 2,071 through 2,085 (of 2,097 total)
  • Author
    Posts
  • in reply to: Table wallet bdd #1844
    alexg
    Keymaster

    Hello,

    I could send you the schema in SQL, but it is safer if you do the following:

    1. Delete the wp_wallets_revision option from the DB:

    DELETE FROM wp_options WHERE option_name = 'wallets_db_revision';

    Make sure to replace wp_ with whatever prefix your DB is using.

    2. After deleting the option, deactivate the plugin and reactivate it.

    I will make a note to make the uninstall script delete the DB revision so that in the future a simple deactivate/reactivate cycle will repair the schema without manual intervention. This will be rolled out in the next release.

    Let me know how it goes.

    regards,
    Alex

    in reply to: Calculator Widget #1809
    alexg
    Keymaster

    Hi,

    A calculator can be implemented as a shortcode/widget on the main plugin, not necessarily as part of the WooCommerce extension.

    This is now on my backlog, thanks for the suggestion. I will try to implement it soon-ish.

    best regards,
    Alex

    in reply to: How to subscribe #1736
    alexg
    Keymaster

    Hello,

    If you wish to gain access to the premium plugins you will need to visit the homepage at https://www.dashed-slug.net and click the button that says “Become premium dashed-slug member”. Membership costs $9.95 per 3 months. All the benefits of premium membership are listed on that same page.

    thanks and regards,
    Alex

    in reply to: Faucet dont show Captcha #1724
    alexg
    Keymaster

    Thank you so much for reporting this and for taking the time to debug the root cause!

    You are of course correct, when a site uses SSL (as it should, nowadays), the correct API endpoint is secure-api.solvemedia,com. If it does not, then it’s api.solvemedia.com. Source: https://solvemedia.zendesk.com/hc/en-us/articles/203648204-Implementing-Over-HTTPS

    This change is implemented in the faucet version 1.1.2.

    Again thanks, I appreciate it.

    regards,
    Alex

    in reply to: Faucet dont show Captcha #1721
    alexg
    Keymaster

    I have found why the captcha is not shown.
    In the file /wallets-faucet/includes/claim.php i have canged
    //api.solvemedia.com/papi/…. to
    //api-secure.solvemedia.com/papi/….

    now it works

    in reply to: Fatar Error #1700
    alexg
    Keymaster

    Hi, can you please check the following:

    1. You can only set a faucet owner to be a user with the manage_wallets capability. Check that you have at least one user with that capability.

    2. Once you do successfully set a user, you will not be able to claim funds from the faucet while logged in as that user. You will need to setup another account to test the faucet.

    Also, are you on a multisite installation?

    regards,
    Alex

    in reply to: Fatar Error #1694
    alexg
    Keymaster

    OK I had a look and I will post a short and a long explanation:

    Short version:
    You can delete the file wallets-faucet/includes/third-party/class-tgm-plugin-activation.php and your immediate problem should go away.

    Long version:
    TGMPA is a very common library for tracking dependencies among wordpress themes and plugins. For this reason, many authors use it. The version that I have included into the faucet plugin, TGMPA 2.6.1, is careful enough to not re-declare itself if it is already declared. The error you are getting is triggered from your meta4delicious theme, which I assume has an older version of TGMPA, that did not do that check.

    I would recommend that you let the author of that theme know about this, so they can update to a more recent TGMPA version.

    Let me know if deleting the file fixes your problem.

    regards,
    Alex

    in reply to: Fatar Error #1693
    alexg
    Keymaster

    Thanks for reporting this.

    I will fix it and release a new faucet version soon.

    I will let you know when the fix is out.

    regards,
    Alex

    in reply to: Support for other coins #1691
    alexg
    Keymaster

    The plugin does not call any of those methods.

    There is no premium version of the plugin, but there are some premium extensions to it.

    All is explained on the homepage https://www.dashed-slug.net

    regards,
    Alex

    in reply to: Support for other coins #1689
    alexg
    Keymaster

    Remember to set sane values to transaction fees on plugin activation.

    in reply to: Support for other coins #1688
    alexg
    Keymaster

    Hello,

    And thanks for your kind words.

    Yes, pretty much. If your coin is a clone of Bitcoin that retains most of its JSON-RPC API intact, then it should be just a matter of replacing strings. You can start from the litecoin adapter which I consider the reference implementation.

    Litecoin RPC Adapter extension

    From time to time I update the litecoin and other adapters. Simply remove the ds-update.php file before redistributing your plugin extension.

    Start by looking here: https://www.dashed-slug.net/developers-coin-adapters-api/

    in reply to: Bitcoin daemon error #1677
    alexg
    Keymaster

    mumiea, what have you tried? Did you check your firewall on the VPS site?

    in reply to: Bitcoin daemon error #1669
    alexg
    Keymaster

    Also, keep in mind that after editing the .conf file you should restart your daemon for the changes to take effect.

    in reply to: Bitcoin daemon error #1668
    alexg
    Keymaster

    While it is true that VPSs don’t allow you to constantly use 100% CPU, this should not be a problem, as you’re not supposed to CPU-mine anything. Not only is CPU mining bitcoins terribly inefficient as of 2017, but it has nothing to do with maintaining a wallet. It is true that while synchronizing the blockchain the wallet uses the CPU a bit more as it is confirming blocks, but after it synchronizes, CPU usage should be minimal.

    If the box is still showing then that means that for whatever reason the wallet is still not connecting. Have a look at the adapters page, and specifically at the status column for your bitcoin adapter. There should be more information about why the plugin is not connecting.

    in reply to: Not see in panel #1655
    alexg
    Keymaster

    Hello,

    The WooCommerce payment gateway settings do not appear under the Wallets tab, rather they appear together with the other payment gateways in WooCommerce → Settings → Checkout → Bitcoin and Altcoin Wallets as described in the instructions.

    If you find this path hard to remember, you can go to Plugins and find the WooCommerce Cryptocurrency Payment Gateway extension. It will have a link to “Settings” under the plugin name.

    regards,
    Alex

Viewing 15 posts - 2,071 through 2,085 (of 2,097 total)