I reply to all queries on the forums and via email, once per day, Monday to Friday (not weekends).

If you are new here, please see some information on how to ask for support. Thank you!

Visitor's browser suspended when creating wallet

dashed-slug.net Forums General discussion Visitor's browser suspended when creating wallet

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #2495

    When a member joins, a wallet is created and the visitor’s browser pauses (about 20-30 seconds).
    There are only these issues when user sign up for the first time.
    (Especially for iPhone Safari, User get a timeout error message)

    Is this issue due to the ajax call you mentioned last time?



    I do not believe so.

    Additionally, there is no “wallet creation” per se. There is one wallet per coin and the plugin does not perform additional tasks when a new user joins.

    1. Do you experience the slowdown on the server or client side? It sounds like it is on the server side.

    2. I believe you mentioned earlier that you have a large number of users on your site. This could cause the timeout message. Try to disable the send_funds_to_user capability so the plugin does not attempt to send the list of usernames to the client. This will be resolved much later in version 3.0.0 as discussed, because it is an architectural change to the API.


    Thanks for helping me understand.
    There are no users yet and I have tested it in various ways.
    In my case, the loading time I talked about is only on the client side, with no load on the server side.
    The ‘send_funds_to_user’ function was turned off except for the administrator.
    When using a coinpayment adapter, it seems like the loading time is getting longer as more coins are applied.
    I’ll try some more tests.


    There is a lot of improvement that can be done to the performance of the front-end JavaScript code. The way coins are indexed internally is currently suboptimal.

    I will do something about it as time permits. Adding it to the list 🙂

    As always, thanks for reporting!


    I tried a little more and found a reason.
    In the Wallets frontend settings, I left the Live polling settings value blank instead of ‘0’
    ( Both ‘Coin info poll interval (minutes)’ and ‘Transaction list poll interval (minutes)’ ).

    I changed the value to ‘0’ as instructed and the delay is gone.
    When blank, there was a big delay when the user first joined. (only frontend)
    Now that i have entered 0, there is no delay.


    Thank you for finding this.

    I will fix the issue so that if you enter nothing it will be interpreted as a zero.

    The fix should be out today.


    In version 2.13.5 there are tighter restrictions on user input, and the polling interval sent to the front-end is always a number.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.