Open extra topbar

Problem with Extension TOR

If you are new here, please see some information on how to ask for support. Thank you!

Problem with Extension TOR

This topic contains 42 replies, has 2 voices, and was last updated by  alexg 1 year, 11 months ago.

Viewing 15 posts - 1 through 15 (of 43 total)
  • Author
    Posts
  • #1846

    aqwzsxedc
    Participant

    Hello,

    I currently have a lot of trouble getting your extensions running on my site.

    I will explain in detail:

    My goal being to provide a Marketplace on the TOR network.

    The problem I encounter with the “Coinpaiement” extension is that the “wallet shortcodes” page is not displayed correctly.

    So I do not have a deposit address automatically issued by the site => “https://coinpaymtstgtibr.onion” which is, more or less the version of => “https: //www.coinpayments. net “on the tor network.

    Can you tell me if this extension can fit to run on the tor network?

    I also want to specify that the adapter communicates well with the wallet which is on the site “https://coinpaymtstgtibr.onion” (status = Responding)

    Perhaps a configuration problem on the site in question?

    I really hope there is a solution to my problem 🙂

    Cordially.

    #1861

    aqwzsxedc
    Participant

    Up please.

    #1868

    alexg
    Keymaster

    My apologies I somehow missed your question while doing other stuff.

    I have not tested the site with tor. Did you edit the PHP code and change the API endpoint?

    I will try it out and let you know, in the meantime you could check your logs if you like.

    regards,
    Alex

    #1871

    aqwzsxedc
    Participant

    Hello,

    There is no problem, I can understand that you are busy on something else 🙂

    I’m not yet touching the PHP code.
    It seems to me that one must activate a connection with a proxy so that it works with the network tor, one can do it with a “Curl”

    I wish (if possible and according to your availability) that you indicate to me or I could add this code PHP in your plugin so that the connection is made correctly between the portfolio and the network tor.

    Example of php code:

    curl_setopt ($ ch, CURLOPT_HTTPPROXYTUNNEL, 1);
    curl_setopt ($ ch, CURLOPT_RETURNTRANSFER, 1);
    curl_setopt ($ ch, CURLOPT_PROXY, ‘192.168.251.1:9050’);
    curl_setopt ($ ch, CURLOPT_PROXYTYPE, 7);
    $ vipbtc = curl_exec ($ ch);
    curl_close ($ ch);

    Do you understand the principle?

    Is the problem of the balance of the member (which does not update) that I am exposed to you by mail, perhaps comes from a lack of proxy? what do you think?

    If you have a solution to make your plugin work under the digital network, I am taker 🙂

    Thank you for your support.
    Cordially.

    #1872

    alexg
    Keymaster

    If you want to connect over tor, at the very least I imagine that the API endpoint should be an onion address, so that’s one reason why it doesn’t work. The PHP code that you sent me is already in there, but the adapter is not meant to connect to the tor API of CoinPayments.

    Unfortunately to test and debug this I will need to setup a tor site and this will take me some time because I’ve never done it before.

    In the meantime, you could try editing the line in wallets-cp.php that reads

    const API_ENDPOINT_URL = 'https://www.coinpayments.net/api.php';

    Make it point to their API endpoint at their onion address and see if it works. It’s worth a shot.

    User balances update automatically when a deposit is inserted into your DB and its status changes to done. This happens once a transaction reaches the required number of confirmations. If the deposit does not appear in your transactions table, even in unconfirmed state, then that means that it was not discovered by the cron mechanism for some reason. We will need to debug this.

    If you wish, you could enable and check your WordPress logs, and let me know if you see anything suspicious.

    #1877

    aqwzsxedc
    Participant

    test

    #1878

    aqwzsxedc
    Participant

    Hello again,

    I am sending you an e-mail because I am unable to reply to your message here:
    I just tried your method on the file “wallets-cp.php” indicating the .onion link, but with this one, I find myself with an error message in the adapter which is:

    Bitcoin and Altcoin Wallets: CoinPayments Adapted failed to discover list of available corners: file_get_contents () returned false

    No communication with the plugin “Coinpayment”.

    215/5000
    I activated debeug mode on WordPress, and I notice this message that worries me …

    The Bitcoin on CoinPayments adapter failed on get_balance (): file_get_contents () returned false, referer: http: // ………..

    #1879

    aqwzsxedc
    Participant

    I think that adding a proxy in the code of the “wallets-cp.php” file with the “Curl” function is necessary for the plugin to communicate well with the coinpayment site.

    Example:

    curl_setopt ($ ch, CURLOPT_PROXY, ‘IP MY SERVER: 9050’);
    curl_setopt ($ ch, CURLOPT_PROXYTYPE, 7);

    What do you think?

    #1880

    alexg
    Keymaster

    Hi,

    You have brought up a number of points, let me answer as many of them as I can:

    First, I do not know if you can use the block.io service over tor. At least the API URL doesn’t seem to be contactable from within tails. That would explain why it didn’t work for you.

    The CoinPayments adapter can possibly work with the curl parameters that you mentioned, I haven’t tested it though. If you have tested it, I would very much like to know what you found, otherwise I will try to make it work myself at some later time and release a patch if needed.

    The process to switch to another adapter is as follows (I will add it to the FAQ):

    1. Deactivate the first coin adapter
    2. Delete your deposit addresses. Simply do a
    DELETE FROM wp_wallets_adds WHERE symbol IN ('BTC','LTC','DOGE');
    in your SQL console. This will let new deposit addresses to be generated by the new adapter. If you do not do this your deposit addresses will be from the old adapter/wallet.
    3. Install and activate the new adapter.

    The CoinPayments adapter is well-tested over clearnet. Can you confirm that you can use it over clearnet? That would eliminate the possibility that you’re doing something else wrong. If it works over clearnet but not tor then we can work from there.

    Also, stepping back from the details, you are obviously interested in anonymity, so I believe you might be better off setting up your own wallet, rather than using a third-party service. I’m curious, why don’t you try to install your own Bitcoin wallet on a server? I normally recommend users against this, but you seem to be one of the edge cases who might be better off doing this.

    If you do not want to keep the entire blockchain online, you could use the built-in Bitcoin adapter with this wallet:

    https://github.com/prasos/bittiraha-walletd

    In any case, make sure to only have only one adapter enabled for each coin that you use. The plugin will warn you about this.

    Let me know how it goes.

    #1881

    alexg
    Keymaster

    My mistake, block.io is contactable over tor:

    $ curl --socks5-hostname localhost:9050 https://block.io/api/v2/get_balance/?api_key=foo
    {
      "status" : "fail",
      "data" : {
        "error_message" : "Invalid value for parameter API_KEY provided."
      }
    }

    You might be right about those curl attributes! Did it work for you?

    #1882

    alexg
    Keymaster

    OK I’ve got it working, using your suggestion.

    I will release a patch soon to the coinpayments adapter. There will be an option to enable tor.

    Thanks very much

    Alex

    #1884

    aqwzsxedc
    Participant

    I will try to work on coinpayment, and I will come back to you.
    The goal is to have at least one of the two plugins that works, so that I can keep the anonymous.

    #1887

    aqwzsxedc
    Participant

    Ah, I’m glad to hear you say that.

    Congratulations to you.

    It will be necessary to think that the IP of the Server Proxy as well as the PORT can be modified in the options of TOR that you will add to the plugin, so that one can subsequently modify the IP of our Server as well as the Port of TOR (9050 or 9150).

    I congratulate you, and I look forward to this upgrade.

    Cordially.

    #1899

    alexg
    Keymaster
    #1900

    aqwzsxedc
    Participant

    Hello,

    Congratulations for the speed of the update, I just installed this one but it remains unfortunately a small problem.

    I disable the plugin, empty the wp_wallets_adds tables from their old repository address, and re-enable the plugin.

    I have taken the trouble to activate the desired currency (BTC), save the connection option on TOR (IP / PORT), and well inform the “Private / Public Key”, “Market ID”, “IPN Security” .

    Only the “wallets shortcodes” page remains empty, no repository addresses appear …: (see screen)

    https://pixsecure.xyz/mrLcs1/BdPgI6.jpeg

    The communication of the coinpayment adapter is OK: (see screen)

    https://pixsecure.xyz/MXgOvl/AZR9wb.jpeg

    Do you think the problem can come from the configuration of the wallet coinpayments in itself, or the plugin?

    I also remind you that I always use the site .onion of coinpayments, this one => https://coinpaymtstgtibr.onion/

    Can this be the problem?

    Looking forward to a return of your share, Regards.

Viewing 15 posts - 1 through 15 (of 43 total)

You must be logged in to reply to this topic.