Open extra topbar

Page Header problem since update.

If you are new here, please see some information on how to ask for support. Thank you!

Page Header problem since update.

dashed-slug.net Forums General discussion Page Header problem since update.

Tagged: , ,

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #3902
    clickforafrica
    Participant

    Hi, I’ve been getting a messed up page header where the WP toolbar spills into the page – hard to describe, screenshot attached.

    I disabled all plug-ins and the problem was gone, then narrowed it down to wallets plug-in, or at least it happens even when only the wallets plug-in is on.
    https://postimg.cc/image/ufkp18ga1/

    Hope you can bring some insight!
    Thanks
    andy

    #3912
    clickforafrica
    Participant

    Adding more detail in case it helps.
    On pages that don’t contain wallets data, the wordpress toolbar has a small search icon at the top right,
    https://postimg.cc/image/sql9426kp/
    When clicked, this expands horizontally to present a text input field,
    https://postimg.cc/image/5p4nybemx/
    But where wallets is activated, it seems to have the whole search box already active and showing below where it should be.
    https://postimg.cc/image/wa76tv1kp/

    #3917
    alexg
    Keymaster

    It is possible that this is related to this problem. Could you edit the fragments.php file and see if this is solved?

    kind regards

    #3935
    clickforafrica
    Participant

    Hi yes, there was a “wa” on line 295 which I removed. I flushed the cache and the search field no longer hangs down into the menu area.

    Strangely though, it is stuck in the open mode still, unlike any other pages.
    https://postimg.cc/gallery/hpcc74oq/

    While I was doing this the update became available so I installed it. The situation is still the same, I took the screenshots after the update and flush cache.

    Still, at least it’s not obstructing anything now! Thanks

    #3947
    alexg
    Keymaster

    Hello,

    Is there any way I can login to your site to check what’s wrong?

    I am having difficulty reproducing the problem.

    #3958
    alexg
    Keymaster

    Hello again,

    I used the credentials you sent me to login. With your help I was able to locate the problem in the knockout template for the balances list view.

    If you want to correct the problem right now, you can edit the file wallets/includes/views/balance/list.php. The <form> tag does not have a matching closing </form> tag, but a </div> tag. This is my mistake and I will of course fix it in the next patch release.

    Thanks again for helping me find the problem.

    kind regards

    #3973
    clickforafrica
    Participant

    That solved it, all looking good now.
    Thanks a lot 🙂

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.