Open extra topbar

Moved: Withdrawals not working

If you are new here, please see some information on how to ask for support. Thank you!

Moved: Withdrawals not working

Tagged: 

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #7532
    cryptofx
    Participant

    While you are at least able to get to that end of sending, mine has never worked for a week now and I am asking if there’s anybody who can look into my site maybe to help me know where I am going wrong. Will appreciate
    Cryptofx Invest
    email me for notification info@riconets.com

    #7534
    alexg
    Keymaster

    Hello,

    I can help you debug this. Please tell me the following:

    1. What is the issue? Is this on a new site or did withdrawals work before?

    2. In the admin dashboard, under “Bitcoin and Altcoin Wallets”, what do you see next to “Cron jobs last ran on” and “Cron jobs last runtime (sec)”?

    3. Go to the Wallets -> Transactions admin screen. After submitting a new withdrawal, does its status stay at “unaccepted” ? Or does it become “pending” and eventually “failed” after a while?

    4. If the withdrawal becomes “failed”, does the user receive an email with an error message?

    5. Please check that you have enough funds in your hot wallet.

    6. Please check that the CoinPayments API key has the correct permissions. This is described in step #23 of the installation guide: https://www.dashed-slug.net/bitcoin-altcoin-wallets-wordpress-plugin/installation-instructions-web-wallet/

    Please reply to all of the above if possible. If after checking all of the above the problem remains, I can login myself to investigate.

    P.S. I have moved your post to a new thread as it was not relevant to the other thread.

    #8800
    Brad
    Participant

    I am having the same problem. As soon as I click the “Send” button a message immediately pops up that says Could not contact server. Status: error Error:”

    Everything else works. I have made deposits and they show in the transaction log but the failed withdrawals do not show in the logs. There is no error email sent.

    IPN debugging
    Last IPN error:
    none
    Local time of last error:

    I have double checked the IPN secret

    Cron jobs last ran on:
    Fri, 10 Jul 20 17:10:36 +0000
    Cron jobs last runtime (sec):
    0
    Cron jobs peak memory (bytes):
    15,747,064
    Cron jobs memory delta (bytes):
    2,208

    Any ideas?

    #8801
    Brad
    Participant

    Still not working but this looks wonky… Withdrawal lock is on (see screen shot)

    Attachments:
    You must be logged in to view attached files.
    #8803
    Brad
    Participant

    Settings look okay (see screen shot)

    Attachments:
    You must be logged in to view attached files.
    #8805
    Brad
    Participant

    Last post just showing the error (see screen shot)

    Attachments:
    You must be logged in to view attached files.
    #8819
    alexg
    Keymaster

    Hello,

    Ok this is a strange one indeed.

    Normally withdrawals are entered into the DB when you click “withdraw”, and they are later executed by the cron job. In your case it seems that the withdrawal is not entered into the DB. (You mentioned that the withdrawal is not shown in the Admin transactions list screen).

    The withdrawals lock should be shown unlocked (open padlock) in all cases, except if you have not entered the public or private key correctly. The public and private keys are two 64-character hex strings. The status of the coin adapter is “Responding”, so this means the keys must be correct. Therefore, the adapter’s withdrawals must be unlocked. I believe that your padlock is unlocked but looks locked due to your font and/or antialiasing. Hover the mouse over the padlock. Does it say “Withdrawals locked” or “Withdrawals unlocked”? It should say “Withdrawals unlocked”.

    After entering a withdrawal and clicking the “Withdraw” button, the withdrawal request should show up in the transactions list, or there should be a meaningful error message. Instead, you got an empty message back in the popup window. I suspect that the JSON API withdrawal request could be cached, so disable all types of server-side caching before trying again.

    If you get the same empty error message back, this could indicate another unexpected error. The only way to know is to enable debugging in your wp-config.php, retry a withdrawal, and look at the logs in wp-content/debug.log.

    The most likely explanation is that maybe there was an SQL error while inserting the withdrawal row into the table. Have you exported/imported the DB from another host?

    In any case, let me know what you find in the debug log. This is not a typical error, otherwise you would be seeing an error message.

    In conclusion, please do this:

    1. Check the withdrawal lock by hovering over the padlock with the mouse. What do you see?

    2. Disable server-side caches.

    3. Enable PHP logging in wp-config.php.

    4. Retry a withdrawal.

    5. Check the debug log. What do you see?

    Let me know what you find.

    with regards

    #8825
    Brad
    Participant

    It turns out that I was able to withdraw BNB and BTC from this account. It’s just ETH that is still not working.(of the 3 coins I tested)

    1. Hovering over the locked icon shows: Wallet unlocked. withdrawals will be processed. The lock image is still locked so that is perhaps a bug

    5. Debug log:
    I get no error when the ether fails

    I got this when the BTC arrived but nothing when I sent some:

    [13-Jul-2020 18:06:22 UTC] Bitcoin and Altcoin Wallets: CoinPayments Adapter received IPN: #deleted by me for this post

    #8830
    alexg
    Keymaster

    OK, in that case, it is likely that Ethereum was under maintenance at the time.

    The lock is shown correctly, this is an issue with your font. If you look closely in your screenshot, the padlock is open. I will add text next to the icon to make the lock status clearer.

    About the withdrawal: Do you actually see a withdrawal entry in the transactions list now?

    Can you go through this checklist and let me know what you find? https://www.dashed-slug.net/how-to-debug-outgoing-withdrawal/

    Alternatively I can login to check myself, contact me by email if you like so we can arrange it. But I will need access to your logs and edit access to the plugin code, so this is not the easiest solution. If you can, go through the checklist above and let me know what you found.

    with regards

    #8835
    Brad
    Participant

    The transactions still do not show up on the transaction list when trying to withdraw ETH. I’ve gone through the checklist and completed every check.

    This is the only thing strange in the debug log for CoinPayments:

    [13-Jul-2020 22:32:26 UTC] The cron_discover_withdrawals cron job failed with: PHP curl returned error: OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to http://www.coinpayments.net:443 If this error does not help with troubleshooting this issue let me know and I’ll send you and email.

    thanks.

    #8840
    alexg
    Keymaster

    OK this problem is likely due to the error you reported. Let me do some research on it and I’ll get back to you.

    In the meantime, since this could be an SSL issue, you could check to see if your server’s date and time is set correctly.

    with regards

    #8844
    alexg
    Keymaster

    OK, here’s a few notes about the withdrawal issue you’re experiencing:

    1. About the SSL error triggered on cron_discover_withdrawals: This is a job that replaces the CPID with the actual blockchain TXID for withdrawals. For this job to succeed or fail, the withdrawal must have been completed already. This error could occur at random from time to time. So please tell me this: When you performed the BNB withdrawal, in “Wallets” -> “Transactions” the TXID column in your admin screen would initially show CWEG3KI3F9QZTE5X0M14MG4OMM. After the withdrawal was processed, there would be an actual TXID assigned by the blockchain. As the cron_discover_withdrawals cron jobs runs, it replaces these CPIDs with TXIDs when they become available, in this case DAE8DC0546BEB259C31101A00AB2FF1B4C56FBA212E17B7BE3AD8F4AAC595429. Do you see the TXID in “Wallets” -> “Transactions”, or do you see the CPID? By now the TXID should be shown.

    2. The error you get when attempting to withdraw Ethereum is something else entirely, and has nothing to do with CoinPayments. Unfortunately this is not an error I’ve seen before and I can’t imagine what’s causing it, so I have to check everything. If you want me to investigate, I will have to debug this on your server. Please contact me over email. Let me know if this is a live site or not, and take a full site backup if it is, just in case. I will have to disable plugins and enter debugging code into the plugin to investigate (I will need admin priviledges). And I will also need access to your PHP log to check how far the code runs before it breaks.

    3. You mentioned that you went through the checklist. What did you mean by “completed every step”? You have already mentioned that the withdrawal is not shown in the admin screens, so surely all the checks must have failed.

    #8846
    Brad
    Participant

    Thanks for following up.
    2. I’ll contact you with site details for debugging.

    3. I meant I went through the steps not every check was valid(your point about the transaction not showing up) and nothing fixed the issue.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.