Open extra topbar

message "No currencies enabled"

If you are new here, please see some information on how to ask for support. Thank you!

message "No currencies enabled"

dashed-slug.net Forums Exchange extension support message "No currencies enabled"

This topic contains 8 replies, has 2 voices, and was last updated by  alexg 6 months, 3 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #5602

    cryptoshade
    Participant

    Good day
    In the withdraw, deposit and transfer pages it says on top: No currencies are currently enabled.
    Currencies are enabled and their status is “Responding” under adapters.
    Also, in Deposit, the QR appears but no addresses are shown in the address field.
    What can be the issue?

    screenshot
    sc2

    #5604

    cryptoshade
    Participant

    I just found this..

    No currencies are currently enabled.

    I am checking the options now..
    Regards

    #5606

    cryptoshade
    Participant

    I added notes to the original post about this issue in the above mentioned link…

    #5618

    alexg
    Keymaster

    Hello,

    Thanks for reporting and posting your progress.

    It is true that some security plugins can interfere with the JSON API. This caused a crash on the frontside JavaScript which then caused the knockout.js UIs to not get updated.

    I will look at how to warn the user if “Hide My WP” hides the JSON API! There should be a setting in every security plugin to exclude certain pages or types of calls from being cached. The JSON API is based on GET parameters, so look for something that disables caching on pages with GET parameters in the query string.

    with regards

    #5620

    cryptoshade
    Participant

    Thanks Alex, for the reply..
    In fact, Hide My WP works fine with the plugin. However Wordfence does not.
    I advise to use Hide My WP along with the exchange..

    #5627

    alexg
    Keymaster

    Thanks. Wordfence works fine with the plugin, as do all server side security or cache plugins. But it might need a little tweaking in your case.

    It is possible that the issue is related to IP geolocation or some other setting. The main thing to check is that the JSON API returns correct and recent data via your browser. All plugins can be configured to exclude requests with GET parameters from caching and/or blocking.

    with regards

    #5628

    cryptoshade
    Participant

    Good to know…
    Thanks for the details, and I am sure it was something I did with the settings.
    The fresh installation works great.

    #5629

    cryptoshade
    Participant

    So, can Cloudflade’s caching be a problem?

    #5659

    alexg
    Keymaster

    Yes, anything can cause problems if it blocks or caches the plugin’s JSON API. So, caching plugins and security plugins are the usual culprits. Requests with the __wallets_action GET parameter must be allowed to run unmodified. You should be able to configure any such plugin to exclude these requests.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.