Open extra topbar

No currencies are currently enabled.

If you are new here, please see some information on how to ask for support. Thank you!

No currencies are currently enabled.

dashed-slug.net Forums CoinPayments.net Coin Adapter extension support No currencies are currently enabled.

This topic contains 6 replies, has 3 voices, and was last updated by  alexg 1 month, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #5391

    scorza420
    Participant

    Hello, I’m having trouble installing. I have been able to set everything up, and the currency chosen appears as ✅ Responding within adapters, and is correctly selected within the coinpayaments, with the correct permissions, including create_transaction.
    however, when linking to the frontend using the shortcode [wallets_deposit] it displays No currencies are currently enabled.

    Any indication?

    Attachments:
    You must be logged in to view attached files.
    #5394

    alexg
    Keymaster

    Hello,

    If you have followed the video instructions, it’s possible that the problem is a missing permission on the API key: get_callback_address. This is mentioned in a pinned post under the video and also in the troubleshooting instructions on the coin adapter’s homepage.

    Please let me know if you continue to experience this issue after enabling the permission.

    with regards

    #5395

    scorza420
    Participant

    I previously talked about create_transaction, I meant get_callback_address.

    I watched the video and activated it. to all are 7 active permissions, correct?

    Attachments:
    You must be logged in to view attached files.
    #5415

    alexg
    Keymaster

    Hello,

    The permissions should be as shown at step 23 of this guide: https://www.dashed-slug.net/bitcoin-altcoin-wallets-wordpress-plugin/installation-instructions-web-wallet/

    You will also need get_withdrawal_info.

    1. As for the issue you are experiencing, have you checked the Troubleshooting section of the manual? (The manual is the PDF in the bundle download of the plugin).

    2. It is possible that you may have an error in your JavaScript console. The plugin requires JavaScript to update the views, so please check.

    3. Navigate to https://example.com/?__wallets_apiversion=3&__wallets_action=get_coins_info where example.com is your domain name. Do you see your coins listed? If not, it is possible that this JSON API response is erroneously cached on your server, so try refreshing your server cache to check if this is the problem.

    Please let me know if the above does not help.

    with regards

    #5605

    cryptoshade
    Participant

    Hello
    When we choose a static single coin in the short-code, any active coin, the address appears successfully.
    But when we do not specify any coin it gives the: “No currencies enabled.”
    I checked the troubleshooting in the manual…
    What could it be?
    This is the error in console, Not sure if it relevant:
    knockout-latest.js:73 Uncaught TypeError: Unable to process binding “style: function(){return {‘background-image’:’url(‘+ coins()[ selectedCoin()].icon_url +’)’} }”
    Message: Cannot read property ‘icon_url’ of undefined
    at style (eval at parseBindingsString (knockout-latest.js:69), <anonymous>:3:390)
    at update (knockout-latest.js:99)
    at function.N.K.l (knockout-latest.js:73)
    at Function.$c (knockout-latest.js:52)
    at Function.ad (knockout-latest.js:52)
    at Function.da (knockout-latest.js:51)
    at Object.N.u.N.K (knockout-latest.js:49)
    at knockout-latest.js:73
    at Object.D (knockout-latest.js:11)
    at s (knockout-latest.js:72)

    #5609

    cryptoshade
    Participant

    Hello again..
    Sorry for the multiple replies. I post updates as I encounter. But I hope all this will help someone.
    The problem is not related to the plugin itself. It is something with WP. I installed a fresh copy and it works like a charm.
    I guess some plugin caused a conflict, so installing a fresh copy then checking the functions after each one can help identifying the cause. Security plugins can block API access.
    Use Hide My WP for security. It is lightweight yet powerful security addition. It is a better choice in this case the Wordfence in this case.
    Best to all.

    #5619

    alexg
    Keymaster

    Hello,

    Thanks for reporting and posting your progress.

    It is true that some security plugins can interfere with the JSON API. This caused a crash on the frontside JavaScript which then caused the knockout.js UIs to not get updated.

    I will look at how to warn the user if “Hide My WP” hides the JSON API! There should be a setting in every security plugin to exclude certain pages or types of calls from being cached. The JSON API is based on GET parameters, so look for something that disables caching on pages with GET parameters in the query string.

    with regards

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.