Open extra topbar

Deposit not working?

If you are new here, please see some information on how to ask for support. Thank you!

Deposit not working?

This topic contains 27 replies, has 3 voices, and was last updated by  alexg 1 year, 9 months ago.

Viewing 15 posts - 1 through 15 (of 28 total)
  • Author
    Posts
  • #2022

    envision
    Participant

    So I configured everything as it should.

    Screenshot showing adapters are responding;
    http://i.imgur.com/DPjNs87.png

    Screenshot of which coin to accept;
    http://i.imgur.com/4NbaEtC.png

    Screenshot showing that the funds did indeed deposit to CoinPayments;
    http://i.imgur.com/af5CflE.png

    Screenshot of the page showing the balance;
    http://i.imgur.com/8MJfDCM.png

    While the deposit was being confirmed, it wouldn’t show up in the transactions list, still doesn’t.

    #2024

    alexg
    Keymaster

    Hello,

    Could it be that you are running WordPress on a machine in your local network?

    Deposit notifications come to your WordPress from the CoinPayments platform via their IPN mechanism. This is HTTP/HTTPS requests coming from CoinPayments. If your installation is not facing the outside world you will either have to install on a VPS or otherwise set up your firewall to forward these requests.

    Check your IPN history in CoinPayments and see if the notifications succeed.

    let me know

    regards,
    Alex

    #2027

    envision
    Participant

    I am indeed hosting it locally whilst I develop the site, didn’t think that would affect it.

    Under IPN history, nothing is there, so I guess you’re right about having it not hosted locally.

    Is there no other possible explanation? Assuming that it could be something else.

    #2045

    envision
    Participant

    Ok so I purchased a server and transfered everything on there. Didn’t make any new transactions, but, shouldn’t the old one show up? Or will I have to make a new one so it logs?

    #2046

    alexg
    Keymaster

    If you have transferred the entire database contents then yes the transaction should show up. If you only did an export via the WordPress admin, that would not have transferred the transactions and addresses tables. The tables are normally named wp_wallets_adds and wp_wallets_txs.

    You can also use the plugin to export the transactions to a csv file and reimport them to the new installation: To transfer the transactions, go to Wallets -> Adapters and choose the “export transactions to .cvs” next to each coin whose transactions you want to transfer. You can then go to the new installation to Wallets -> Transactions and at the end of the page, import the csv file. That should transfer your transactions.

    As for IPN history, since you were running the plugin locally, there should be failed attempts listed in your history when you log in to coinpayments. But now that you are running the plugin on a server the IPN requests should succeed.

    #2047

    envision
    Participant

    I exported via MySQL (a full backup), I did another test transaction and that one doesn’t show up either.

    Payment shows up on CoinPayments, but not on my site.
    http://i.imgur.com/dJeITuw.png

    This is my IPN history;
    http://i.imgur.com/XvY7w1H.png

    #2049

    alexg
    Keymaster

    OK, first things first.

    I only mentioned the csv export because I thought you wanted to migrate an existing transaction from one machine to another. If you have not performed any successful transaction yet, just ignore the export/import thing.

    Also, if your IPN history is empty, that means that the CoinPayments platform never attempted to notify the plugin of any deposits. Could it be that you have not setup IPN correctly? Please confirm that you have followed the installation instructions on https://www.dashed-slug.net/bitcoin-altcoin-wallets-wordpress-plugin/coinpayments-adapter-extension/ and in particular the part where you create an IPN secret and set in the coin adapter settings.

    #2050

    envision
    Participant

    Funds are indeed being “read’ from CoinPayments to the site.
    http://i.imgur.com/Jdf1kbP.png

    Added a cron job for;
    http://Mysite.copm/wp-cron.php?doing_wp_cron > /dev/null 2>&1

    IPN secret is set on both my site and CoinPayments.

    There is one problem though, can’t set the IPN callback URL (Dont have a domain yet, so using the direct server IP).
    “The IPN URL can only be HTTPS or HTTP!”,

    Tried with my server’s IP and a few URLs just to see if it’ll save, nothing works.

    Other then that, followed that guide completely.

    #2051

    envision
    Participant

    Managed to set the IPN callback url, had to end with a / (http://MyIP/).

    #2054

    alexg
    Keymaster

    Thanks, I didn’t know about this. I had never tried IPN with IP addresses instead of domain names.

    To clear up any confusion:

    Every time you send cryptocurrencies to a deposit address, CoinPayments will do an HTTP request to your site. We need to know 1) if it is being sent and 2) if it is being received. The “IPN history” page allows you to see both of these things. The screenshots you sent earlier indicated that no messages were being attempted. Probably due to the missing trailing slash.

    At the very least you should now be seeing IPN attempts on CoinPayments, even if the messages do not arrive at your site.

    Let me know how it goes.

    regards
    Alex

    #2056

    alexg
    Keymaster

    Additionally, try leaving empty the IPN URL altogether. There is no need to specify this as it is being set by the plugin on each callback address. The full IPN URL constructed by the plugin is something like http://example.com/?wallets-cp-ipn=1 but you do not need to worry about this.

    #2058

    envision
    Participant

    I tried with and without, nothing works. I’ve literally started from scratch 4x. Followed the tutorial, still doesn’t work.

    You got an instant messenger or something to contact you on? This takes forever to solve and the site needs to get online very soon.

    #2062

    alexg
    Keymaster

    Hello,

    I believe what is happening is this: You generated a deposit address while you had entered an IPN URL. This didn’t work because the IPN URL, if present, should end with ?wallets-cp-ipn=1 . Then I told you to remove the IPN URL but the deposit address you had generated still had a faulty IPN. When you uninstall the plugin, the tables are not being deleted. This is done for safety. So the old deposit address remains. You could try to empty the addresses table. This will force the plugin to regenerate new deposit addresses. You can do this with the following SQL query:

    TRUNCATE wp_wallets_adds;

    making sure to replace wp_ with whatever your table prefix is. Then, try a new deposit to that address. If you want to test with LTCT, you can use this faucet to send testnet Litecoins: http://testnet.litecointools.com/

    Try this and wait a few minutes. The deposit should work.

    If not, we will need to look at the following:

    1. Does the [wallets_deposit] shortcode show you deposit addresses?

    2. Are there IPN attempts in your IPN history?

    3. If there are IPNs what is their status? The CoinPayments platform lets you view whether an IPN message was received or not.

    4. Are there any errors in your logs? Instructions for enabling the logs are here: https://codex.wordpress.org/Debugging_in_WordPress

    Apologies, but I only offer support over email and the forums. This is also mentioned in the terms of service. There are good reasons for this. I do try to reply as quickly as possible whenever I am not sleeping or away from work.

    Give this a try and let me know. Hopefully it will work now, but if not, please answer the above questions so we can find out what’s wrong.

    kind regards

    #2063

    envision
    Participant

    – Completely uninstalled and removed all data.
    – Cleared IPN URL.
    – I enabled Litecoin Testnet, but doesn’t seem to show up in adapters or the shortcode lists.

    1) Yes it shows the deposit address. In fact, I was able to deposit and have the funds show up on CoinPayments, they just don’t show back on the site. http://i.imgur.com/MrUqG9M.png (Note this screenshot was prior to the re-installation, so should work regardless).

    2) IPN history shows “- No IPNs Found -“.

    3) Nothing to show, but, all adapters show as “Responding”.

    4) Logs are enabled, nothing shows up (enabled log file and show errors on page).

    I understand that you probably want me to post here for documentation purposes.

    #2067

    alexg
    Keymaster

    OK you have a somewhat strange problem indeed! Never come accross this one.

    I find it very curious that your IPN history is empty. I assume that by “removed all data” you mean that you also emptied the wp_wallets_adds table. As I mentioned before, this data is not deleted when you uninstall the plugin.

    Here’s what you can check:

    Every time the plugin requests a new deposit address, a “callback address” is generated on the CoinPayments platform. You can then view these callback addresses via the dashboard. For Litecoin testnet, navigate to https://www.coinpayments.net/index.php?cmd=acct_balances&action=deposit&coin=LTCT

    You should see your deposit address listed there. It’s type should be “commercial”. If that’s the case, then when you send funds to that address the platform should attempt an IPN to your site, regardless of what the plugin, or anything on your server, does.

Viewing 15 posts - 1 through 15 (of 28 total)

You must be logged in to reply to this topic.