⚠ IMPORTANT: Action required by admins for version 2.13.0 of Bitcoin and Altcoin Wallets

When you update Bitcoin and Altcoin Wallets to 2.13.0, you will also need to update any cloud-wallet adapters to their latest version.

The upcoming release 2.13.0 of Bitcoin and Altcoin Wallets introduces a change that website administrators must be aware of. These new versions will be released shortly after this announcement.

tl;dr

  • When you update Bitcoin and Altcoin Wallets to 2.13.0, you will also need to update any cloud-wallet adapters to their latest version. These are the block.io adapter (version 2.2.0) and the CoinPayments.net adapter (version 0.6.0-beta). (The RPC adapters for full-node wallets do not need to be updated at this time.)
  • Coin adapters that are in a locked state will no longer process pending withdrawals.

long explanation

Version 2.13.0 introduces a new, optional security feature: Coin Adapters can be in an unlocked or locked state. A Coin Adapter can process pending withdrawals only when it is unlocked. This feature is available for the block.io adapter and all the RPC adapters.

The previous behavior is default. That is, if you have already entered a passphrase or PIN to your coin adapter, then the coin adapter will remain unlocked indefinitely. You can change this behavior in Admin → Cron job → .

To check which adapters are locked and which are unlocked, inspect your adapters list in AdminAdaptersWithdrawals lock.

To learn more about this new feature, read the Transactions section of the documentation, under the subheading “Withdrawals and wallet locks”.

Thank you for your attention in this matter. This change was necessary to increase security of the plugin, and I have tried to make it as painless as possible for the users, but if you do face any difficulties while upgrading, please contact me via the support forum or email.

Alex

Comments:0

Leave a Reply

Your email address will not be published. Required fields are marked *