Open extra topbar

Wrong alert when try wallet less purchase

If you are new here, please see some information on how to ask for support. Thank you!

Wrong alert when try wallet less purchase

dashed-slug.net Forums WooCommerce Cryptocurrency Payment Gateway extension support Wrong alert when try wallet less purchase

Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #8884
    angrybird
    Participant

    Hi,

    When I try to make a payment with the balance in my wallet less than price of the item. It still allows to make purchase then show an alert: “Payment error: No cryptocurrency was selected for payment”

    you can check the screen capture there”

    https://pasteboard.co/JixlP3j.jpg

    1. How did you select a cryptocurrency that has insufficient balance? The payment gateway only presents currencies with sufficient balance as options on checkout.

    –> I’ve tried with new account have an only small balance of BTC and selected a product with price higher than my balance in Wallet. I’ve seen the message on the Purchase page: ” You do not hold enough funds on any cryptocurrency to pay for this order.”. However, I still try to click “Purchase” and saw this message. It might make user confused.

    2. 2. Assuming that your balance has decreased since the checkout page was rendered, was there an order placed? In my tests, if such an edge case occurs, an order is created, but its status is “Pending payment”, so there is no danger of the order being fulfilled. Do you see an order created under “WooCommerce” -> “Orders”, and what is its status?

    –> Yes, the payment status is “Pending Payment”. Did we have anyway when they do not enough the sufficient balance in wallet (offline), it will redirect to an online gateway and allow them paid through scan QR code like a deposit?

    Your support is highly appreciated.

    #8904
    alexg
    Keymaster

    Hello,

    OK thank you for the clarification.

    I still can’t reproduce the issue on my machine, so I’m not sure why it happens.

    I can’t understand how you checked out. To check out using a crypto coin, you must go to checkout, select “Bitcoin and Altcoin Wallets”, and then there is a dropdown with all the currencies that have enough balance to pay for the cart. You are not allowed to select a currency that has insufficient balance.

    Could you please help me reproduce this issue? Please answer all of the questions below:

    1. Are you using the latest version of the gateway? It’s 2.3.2.

    2. Are you using any other WooCommerce plugins?

    3. What’s your store’s default currency? Your store’s default currency is at “WooCommerce” -> “Settings” -> “Currency options” -> “Currency”.

    4. What’s the cryptocurrency you paid with? The currency you paid with is the currency chosen in the dropdown on the checkout page.

    5. Most importantly: Is the exchange rate between these currencies available? To see the available rates, go to “Wallets” -> “Exchange Rates” -> “Exchange rates debug views” -> “Exchange rates”.

    (For example, if you have the BTC_USD rate and the LTC_BTC rate and you try to pay with LTC, while the store currency is USD, then the exchange rate is available i.e. can be computed from available data.

    thank you

    with regards

    #8922
    angrybird
    Participant

    Many thanks, seem I’ve modified the alert and look better.

    #8927
    alexg
    Keymaster

    OK, but see the FAQ under “I want to do changes to the plugin’s code.”

    Also, this doesn’t solve the issue of why you even saw the error in the first place. If you want to investigate this further, disable the other plugins and test the checkout again. Normally the plugin doesn’t allow a user to checkout with a coin that has insufficient balance.

    with regards

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.