Open extra topbar

Wallets are not being generated

If you are new here, please see some information on how to ask for support. Thank you!

Wallets are not being generated

dashed-slug.net Forums CoinPayments.net Coin Adapter extension support Wallets are not being generated

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #3773
    odapps
    Participant

    Hello, I am using this plugin and have configured it correctly (Can view the available coins and choose which ones i would like. However the users on the site are not getting a wallet address (including the admin). I was wondering what I might be doing wrong, as this has not happened before. (not using any security plugins, host is not blocking port, and even reinstalled new plugin)

    #3774
    odapps
    Participant

    This is the error message I get when trying to access the ipn that i found from the trouble shooting section:

    IPN Mode is not HMAC

    #3779
    alexg
    Keymaster

    Hello,

    It does sound like you have checked most things. Make sure that your user roles have the capability has_wallets.

    1. I would suggest that you only enable one coin, such as Litecoin testnet, then wait two minutes and try again. It is possible that some coin that you have enabled triggers an error on the API, and if too many errors occur, the API bans you for two minutes. IF this is the case, then there should be some information in the WordPress logs, once you enable them.

    2. Make sure that the wp_wallets_adds table exists. If it does not, the plugin will warn you about this. In the admin screens there will be an error message at the top of the screen.

    Let me know if this helps.

    kind regards

    #3780
    odapps
    Participant

    I have made sure that the user roles are available for all roles (this is also happening on the admin side)

    Enabled only test net litecoin (user addresses are still not generating, checking via their profile)

    I made sure that the wp_wallets_adds is a row in the database (it is however empty)

    I dont think it is an api error, as this is the second one I am setting up. (have coinpayments on another install with no issues)

    Could it be that failtoban is enabled? I doubt this but have tried so many different things (even using older versions without success)

    Using digital ocean servers if that helps also.

    Here are the plugins and theme I am using (again doubt there is a conflict here)

    Plugins:
    bbPress: v2.5.14
    Bitcoin and Altcoin Wallets: v3.5.6
    Bitcoin and Altcoin Wallets: CoinPayments Adapter: v1.0.6
    Bitcoin and Altcoin Wallets: Exchange extension: v0.2.1-beta
    BuddyDrive: v2.1.1
    BuddyPress: v3.1.0
    Contact Form 7: v5.0.3
    Easy Knowledge-Base: v1.0
    Envato Market: v2.0
    Restrict my site: v1.0.1
    rtMedia for WordPress, BuddyPress and bbPress: v4.5.2
    Visualizer: Charts and Graphs Lite: v3.0.10
    Wise Chat: v2.6.3
    WPBakery Page Builder: v5.4.7

    Theme:
    BuddyApp v1.5.7

    #3781
    odapps
    Participant

    If it helps, I have even tried using the base wordpress theme and no plugins without success..

    #3782
    odapps
    Participant

    Found it, within the coinpayments there are API errors like you mentioned. Below is what the error includes:

    {
    “error”: “This API Key does not have permission to use that command!”,
    “result”: []
    }

    Is there a setting, I have missed within coinpayments?

    #3783
    odapps
    Participant

    I figured it out, transactions, deposits, and withdraws are working now.

    Within your instructions, can you please include that you have to enable certain features within conpayments. I felt like such a noob.

    Also please include the recommended permissions

    Additionally this message will occasionally popup:

    Could not contact server. Status: parsererror Error: SyntaxError: Unexpected token < in JSON at position 619

    Attachments:
    You must be logged in to view attached files.
    #3819
    alexg
    Keymaster

    Hello,

    Good to know that you fixed the problem.

    The installation instructions already mention that you should enable the get_callback_address permission. See step 3 at https://www.dashed-slug.net/bitcoin-altcoin-wallets-wordpress-plugin/coinpayments-adapter-extension/

    About the other error (JSON parse error), please see the troubleshooting guide in the documentation where it is covered extensively.

    kind regards

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.