Open extra topbar

If you are new here, please see some information on how to ask for support. Thank you!

Version of plugin 4.0 gives error and wp stops working.

dashed-slug.net Forums General discussion Version of plugin 4.0 gives error and wp stops working.

Tagged: , , ,

This topic contains 25 replies, has 3 voices, and was last updated by  alexg 9 months, 2 weeks ago.

Viewing 11 posts - 16 through 26 (of 26 total)
  • Author
    Posts
  • #5712

    frodogrguez
    Participant

    cron seems to be running fine, no error is embedded.

    but the withdrawals are not processed, they remain in a pending state.

    by not giving any error I installed a plugin to check the cron and it seems to run correctly.

    I attached the capture.

    I have seen that in the section wallet => Cron
    change to 1 min or 3 min takes about 15 min to rerun, but withdrawals are not processed.

    Excuse my English, I use a translator

    Attachments:
    You must be logged in to view attached files.
    #5714

    alexg
    Keymaster

    Thank you.

    Is it possible for you to provide me with the information I requested in my previous post?

    Namely:

    1. The information found in the dashboard. For example:

    
    Plugin version 	4.0.1
    Git SHA 	3e011ed9
    Web Server 	nginx/1.12.1
    PHP version 	7.0.18-0ubuntu0.16.10.1
    WordPress version 	5.1-beta3-44721
    MySQL version 	5.7.22-0ubuntu0.17.10.1-log
    DB prefix 	wp_
    Is multisite 	false
    Is network activated 	false
    PHP max execution time 	30
    DB storage engine for 'wp_wallets_txs' 	InnoDB
    DB storage engine for 'wp_wallets_adds' 	InnoDB
    Constant 'WP_DEBUG' 	true
    Constant 'WP_DEBUG_LOG' 	true
    Constant 'WP_DEBUG_DISPLAY' 	false
    Constant 'DISABLE_WP_CRON' 	n/a
    Constant 'DSWALLETS_FILE' 	/var/www/wordpress/wp-content/plugins/wallets/wallets.php
    Constant 'WP_MEMORY_LIMIT' 	40M
    PHP.ini 'memory_limit' 	256M
    Cron jobs last ran on 	Thu, 31 Jan 19 13:44:18 +0000
    Cron jobs last runtime (sec) 	4
    Cron jobs peak memory: 	8022672
    Cron jobs memory delta: 	4936
    PHP Extension 'curl' 	Loaded
    PHP Extension 'mbstring' 	Loaded
    PHP Extension 'zlib' 	Loaded
    Active wallets extensions 	wallets-exchange 0.6.0-beta, wallets-fiat 0.2.0-beta, wallets-multiadapter 1.0.5
    Network-active wallets extensions 	n/a 
    

    2. any logs written out when you enable the setting “Wallets” -> “Cron job” -> “Verbose log output (debug)”.

    For example, here’s what I get on my machine:

    
    [31-Jan-2019 13:43:32 UTC] Bitcoin and Altcoin Wallets cron jobs STARTED. Elapsed: 0 sec, Mem delta: 0 bytes, Mem peak: 9159928 bytes, PHP / WP mem limits: 256 MB / 40 MB
    [31-Jan-2019 13:43:32 UTC] Bitcoin and Altcoin Wallets Fiat coin adapter for USD cron job finished. Elapsed: 0 sec, Mem delta: 17544 bytes, Mem peak: 9159928 bytes, PHP / WP mem limits: 256 MB / 40 MB
    [31-Jan-2019 13:43:32 UTC] Bitcoin and Altcoin Wallets Fiat coin adapter for EUR cron job finished. Elapsed: 0 sec, Mem delta: 17544 bytes, Mem peak: 9159928 bytes, PHP / WP mem limits: 256 MB / 40 MB
    [31-Jan-2019 13:43:36 UTC] Bitcoin and Altcoin Wallets Bitcoin core node cron job finished. Elapsed: 4 sec, Mem delta: 4192 bytes, Mem peak: 9159928 bytes, PHP / WP mem limits: 256 MB / 40 MB
    [31-Jan-2019 13:43:36 UTC] Bitcoin and Altcoin Wallets cron jobs FINISHED. Elapsed: 4 sec, Mem delta: 3752 bytes, Mem peak: 9159928 bytes, PHP / WP mem limits: 256 MB / 40 MB
    

    If you can give me the same information from your server, it will help me a lot. Thank you.

    Also, did you check that the adapters are unlocked? Go to the adapters list and check please. If the adapters are unlocked, they will have an open padlock sign such as: 🔓 If they are locked, you will see this: 🔒

    #5715

    frodogrguez
    Participant

    the adapters are unlocked from cron does not throw me any data

    Plugin version 4.0.1
    Git SHA 2a9b64c4
    Web Server Apache
    PHP version 7.2.14
    WordPress version 5.0.3
    MySQL version 5.5.60-0+deb7u1-log
    DB prefix hfldFql
    Is multisite false
    Is network activated false
    PHP max execution time 120
    DB storage engine for ‘hfldFqlwallets_txs’ InnoDB
    DB storage engine for ‘hfldFqlwallets_adds’ InnoDB
    Constant ‘WP_DEBUG’ false
    Constant ‘WP_DEBUG_LOG’ false
    Constant ‘WP_DEBUG_DISPLAY’ true
    Constant ‘DISABLE_WP_CRON’ n/a
    Constant ‘DSWALLETS_FILE’ WP/wp-content/plugins/wallets/wallets.php

    Constant ‘WP_MEMORY_LIMIT’ 512M
    PHP.ini ‘memory_limit’ 512M
    Cron jobs last ran on Thu, 01 Jan 70 00:00:00 +0000
    Cron jobs last runtime (sec) n/a
    Cron jobs peak memory: n/a
    Cron jobs memory delta: n/a
    PHP Extension ‘curl’ Loaded
    PHP Extension ‘mbstring’ Loaded
    PHP Extension ‘zlib’ Loaded
    Active wallets extensions wallets-exchange 0.6.0-beta, wallets-airdrop 1.1.0, wallets-faucet 1.5.0, wallets-multiadapter 1.0.5
    Network-active wallets extensions n/a

    #5716

    bigblue
    Participant

    Alex,

    Regarding the adapters, I checked and they are locked.

    From the dashboard, here is what I get (No verbose log output):

    Plugin version 4.0.1
    Git SHA —
    Web Server Apache
    PHP version 7.2.14
    WordPress version 5.0.3
    MySQL version 10.1.37-MariaDB
    DB prefix —
    Is multisite false
    Is network activated false
    PHP max execution time 600
    DB storage engine for ‘–_wallets_txs’ InnoDB
    DB storage engine for ‘–_wallets_adds’ InnoDB
    Constant ‘WP_DEBUG’ true
    Constant ‘WP_DEBUG_LOG’ true
    Constant ‘WP_DEBUG_DISPLAY’ false
    Constant ‘DISABLE_WP_CRON’ n/a
    Constant ‘DSWALLETS_FILE’ /wallets.php
    Constant ‘WP_MEMORY_LIMIT’ 512M
    PHP.ini ‘memory_limit’ 512M
    Cron jobs last ran on Thu, 31 Jan 19 14:23:07 +0000
    Cron jobs last runtime (sec) 2
    Cron jobs peak memory: 248777064
    Cron jobs memory delta: 331200
    PHP Extension ‘curl’ Loaded
    PHP Extension ‘mbstring’ Loaded
    PHP Extension ‘zlib’ Loaded
    Active wallets extensions wallets-exchange 0.6.0-beta
    Network-active wallets extensions n/a

    In front it seems everything normal, but I did not test any withdrawal.

    Thank you

    #5717

    alexg
    Keymaster

    Thank you both for providing me with the debug info.

    @bigblue If your adapters are locked, then you should not expect any withdrawals to proceed from the pending state to anything else. Unlock the adapters first and the withdrawals will be processed. To do this:

    1. Go to “Wallets” -> “Cron job” -> “Withdrawal locks” -> “Time to retain withdrawal secrets”. Set this either to 0 or to a large value, depending on how long you want to unlock the adapters for.

    2. Go to your adapter settings and set the passphrase. If you have set the passphrase correctly, the adapters will then be unlocked.

    I am also somewhat surprised to see that you are using almost half of the 512MB of memory. But if you have many plugins installed it is possible.

    @frodogrguez Yor cronjob is indeed not running. It’s hard to know why. You have a lot of memory (512MB) allocated to WordPress. I normally test the code only with 40MB. The PHP timeout value is also sufficiently large. I keep mine at 30 seconds, but what you have also works. Also, make sure to enable the debug log in your wp-config.php. It is currently disabled.

    @bigblue @frodogrguez You both say that you do not get any debug output. This is very strange. Can you confirm please? To be clear:

    1. Make sure that you are running 4.0.1, today’s release.

    2. Check “Verbose log output (debug)” and click save settings. (you should have already done this)

    3. Trigger the cron job once via the link provided in the admin settings.

    You can do this via your browser by simply following the link. The result should be a JSON response saying “result: success”

    4. Then check the log file in wp-content/debug.log. There has to be something there. There should be a line that says “cron jobs STARTED”. Then a few more lines. Finally a line that says “cron jobs FINISHED”. Do you see any of this?

    #5718

    frodogrguez
    Participant

    running 4.0.1, wallet unlocked, debug.log

    now again it seems that I have problems with memory

    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieving exchange rates STARTED. Elapsed: 0 sec, Mem delta: 0 bytes, Mem peak: 60392912 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieved known cryptocurrencies. Elapsed: 0 sec, Mem delta: 709864 bytes, Mem peak: 60679072 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieved known fiat currencies. Elapsed: 0 sec, Mem delta: 710616 bytes, Mem peak: 60710048 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieved currency exchange rates. Elapsed: 0 sec, Mem delta: 759824 bytes, Mem peak: 60710048 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieving exchange rates FINISHED. Elapsed: 0 sec, Mem delta: 735344 bytes, Mem peak: 60710048 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieving exchange rates STARTED. Elapsed: 0 sec, Mem delta: 0 bytes, Mem peak: 60394352 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieved known cryptocurrencies. Elapsed: 0 sec, Mem delta: 709248 bytes, Mem peak: 60627976 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieved known fiat currencies. Elapsed: 0 sec, Mem delta: 710000 bytes, Mem peak: 60658952 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieved currency exchange rates. Elapsed: 0 sec, Mem delta: 779312 bytes, Mem peak: 60658952 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieving exchange rates FINISHED. Elapsed: 0 sec, Mem delta: 753936 bytes, Mem peak: 60658952 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieving exchange rates STARTED. Elapsed: 0 sec, Mem delta: 0 bytes, Mem peak: 60392640 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieved known cryptocurrencies. Elapsed: 0 sec, Mem delta: 709864 bytes, Mem peak: 60644440 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieved known fiat currencies. Elapsed: 0 sec, Mem delta: 710616 bytes, Mem peak: 60675416 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieved currency exchange rates. Elapsed: 0 sec, Mem delta: 758648 bytes, Mem peak: 60675416 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [31-Jan-2019 16:05:25 UTC] Bitcoin and Altcoin Wallets retrieving exchange rates FINISHED. Elapsed: 0 sec, Mem delta: 733272 bytes, Mem peak: 60675416 bytes, PHP / WP mem limits: 512 MB / 512 MB

    Attachments:
    You must be logged in to view attached files.
    #5721

    alexg
    Keymaster

    @frodogrguez Thank you. What you see is not an error. It is the debug information I was looking for.

    The debug info shows that exchange rates are downloaded. I do not see any execution of the cron jobs.

    Did you click on the link at “Wallets” -> “Cron job” -> “Perioric tasks”?

    After clicking on the link, are there any lines starting with “Bitcoin and Altcoin Wallets cron jobs STARTED”?

    #5738

    frodogrguez
    Participant

    thank you very much for support. As always the best.

    Finally, it has been solved by restarting the wallets

    Now everything works fine as always.

    Thank you very much and greetings.

    #5739

    alexg
    Keymaster

    Thank you. That’s great news!

    Don’t forget to disable Verbose log output (debug) otherwise your logfiles will fill up quickly.

    with regards

    #5758

    bigblue
    Participant

    Thank you Alex for your support, for the moment everything seems fine.

    Just I get by times the next message on sashboard: The wp_cron tasks have not run in the past 4 hours.You must either enable auto-triggering or trigger cron manually via curl/system-cron. It is normal?

    For withdrawals, I did not check well before, but the padlock was unlocked (not to much visual difference between locked and unlocked)

    Thank you

    Best regards

    #5767

    alexg
    Keymaster

    Glad to hear that the issue was resolved.

    If you see the warning about wp_cron persisting, then you can set up manual cron triggering (ask me how to do this if you are not sure how). If on the other hand you only saw the error once, you can ignore it.

    If you have already set up manual cron triggering and you still see this error, this means that the cron job runs but does not complete. I would need to see the verbose debug output to determine where the job fails.

    with regards

Viewing 11 posts - 16 through 26 (of 26 total)

You must be logged in to reply to this topic.