Open extra topbar

version 4.3.0

If you are new here, please see some information on how to ask for support. Thank you!

version 4.3.0

dashed-slug.net Forums General discussion version 4.3.0

This topic contains 7 replies, has 2 voices, and was last updated by  tanger 3 months, 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #6274

    tanger
    Participant

    I’m trying to update my plugin 4.2.1 to 4.3.0 – When selecting the update through the plugin manager, all seems to run fine with the green “Updated” message. But the plugin does not update, after refreshing the page the plugin wants to update again. Any thoughts? I’ve successfully updated other plugins without issue. Thanks.

    #6275

    tanger
    Participant

    Checking my apache logs, it appears the monero adapter is causing a warning:

    [Mon May 06 19:52:07.951450 2019] [php7:warn] [pid 31168] [client xxx.xx.xxx.xxx:49216] PHP Warning:  Invalid argument supplied for foreach() in .../wp-content/plugins/wallets-monero/includes/coin-adapter-cryptonote.php on line 396, referer: https://mysite.com/wp-cron.php?doing_wp_cron=1557172327.1479079723358154296875
    

    Monero Adapter Status is reporting “Responding” without any errors.

    #6278

    alexg
    Keymaster

    Hello,

    I have investigated this issue and it seems to be a problem with wordpress.org. If you attempt to download the latest version it gives you 4.2.1. I have contacted the good people at wordpress.org and this should be sorted soon. I will keep you updated here about this.

    In the meantime, if you wish to update to version 4.3.0, you can extract the files manually into your wp-content/plugins/wallets directory. The latest plugin zip file can be downloaded from here: https://www.dashed-slug.net/downloads/

    The other warning coming from the Monero coin adapter is not related and does not seem serious. I will investigate. Did you experience any issues with the Monero adapter? If possible, in the future, please post issues with the Monero adapter here: https://www.dashed-slug.net/forums/forum/monero-coin-adapter-extension-support/

    with regards

    #6279

    tanger
    Participant

    Thanks for your reply. Sorry for making a mess of the forum. I’ll take more time to find the correct place to post.

    #6282

    alexg
    Keymaster

    That’s ok, thanks! 🙂 As for updating to the latest version, the issue is fixed now. Thank you for reporting it!

    After communicating with a representative from wordpress.org I found out that the problem was caused by too many svn tags on the repository.

    I followed the official recommendation about deleting old versions. I have now retained only the latest patch release from each major version, plus all the recent minor and patch releases after 4.0.0.

    If anyone needs to download the other releases of the plugin for historical reasons, they are always available in the download section and on github.

    with regards

    #6283

    tanger
    Participant

    Thanks. The plugin update was successful.

    #6715

    alexg
    Keymaster

    The log warning coming from the Monero Coin Adapter extension is now eliminated in version 1.0.2.

    #6717

    tanger
    Participant

    Cool! My error log looks much better!

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.