Open extra topbar

User specific wallet

If you are new here, please see some information on how to ask for support. Thank you!

User specific wallet

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #7926
    ncury1
    Participant

    When I logout, and go to wallets page, it still shows the same wallet address registered to the logged out user.

    Is there a way I can make this more connected using woocommerce?

    When a user logs in, they can choose wallet in the menu to view their wallet?

    Im not sure if the wallets page i created in the video is best suited for this, maybe i need to add some more code

    #7929
    scorza420
    Participant

    I opted for work in a way where only logged in users see deposit addresses.

    for that I used a plugin like hide this and it still allows me to hide function by user role

    #7932
    alexg
    Keymaster

    Hello,

    First of all, as @scorza420 mentioned, it’s a good idea to place the wallet shortcodes in a page that is only viewable by your members.

    However, even if you don’t do this, it should not be possible to see user-specific data such as balances or deposit addresses when you are logged out. If you are seeing this info when logged out, it indicates a problem with your server cache.

    Try this: logout, then go to https://www.example.com/?__wallets_apiversion=3&__wallets_action=get_coins_info (replacing example.com with your domain name) and see what you get. You should normally see a JSON response like the following: {"result":"error","code":-106,"message":"Must be logged in or specify a valid API key"}

    If you instead see actual coin information, you should whitelist the plugin’s JSON-API in your server-side cache plugin(s). This could be “W3 Total Cache”, “WP Super Cache”, “WP-Optimize”, or some other plugin. You can exclude all URLs that have the _wallets_action GET parameter.

    Please let me know if you continue to face this issue.

    with regards

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.