Open extra topbar

Unable to save changes in adapter

If you are new here, please see some information on how to ask for support. Thank you!

Unable to save changes in adapter

dashed-slug.net Forums Full Node Multi Coin Adapter extension support Unable to save changes in adapter

This topic contains 5 replies, has 2 voices, and was last updated by  alexg 2 weeks, 6 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #6538

    tanger
    Participant

    I’m attempting to install a second instance of this plugin (the first is working perfectly). This is a fresh wp install. When attempting to update any coin adapter (I’ve tried bitcoin full node, coinpayments and the other full node coins), the “Save Changes” button at the bottom of the adapter setting page is not selectable. I don’t see anything unusual in the console or apache error log. Do you have any insight on what I’m doing wrong?

    Thanks!

    #6543

    alexg
    Keymaster

    Hello,

    Thanks for reporting, I have not encountered this issue before.

    So you say that the button does exist, but it is not clickable?

    I know you say you checked the log, but I am guessing that a PHP error might be breaking the rendering of the admin page. Normally at the bottom of each admin page for the plugin, there is a message “Found Bitcoin and Altcoin Wallets useful? Want to help the project? Please leave a ★★★★★ rating on WordPress.org!”.

    1. Do you see this message on the coin adapters page?

    2. Are you on a multisite install?

    3. What happens if you deactivate other plugins?

    Please let me know.

    Lastly, if you wish me to login and check it out, you can email me some credentials and I will have a look.

    #6545

    tanger
    Participant

    Thank you. i have the wp installation in a sub directory. e.g. example.com/staging/

    I don’t think this is the issue, as all of the other links and pages are working properly.

    I’m not on a multi install

    The “save changes” button is viewable but you can’t select it to save your changes.

    The button is being drawn kinda weird with zero padding up against the ‘rate the plugin’ footer message.

    Perhaps i should move the install to the root directory and see if that fixes it? And before i waste your time. thanks!

    Attachments:
    You must be logged in to view attached files.
    #6548

    tanger
    Participant

    I think I found something.

    Maybe you can duplicate this error by installing and activating the plugin: Bitcoin and Altcoin Wallets: WooCommerce Cryptocurrency Payment Gateway Version 2.1.0

    I can activate the core plugin along with a full node adapter or coinpayments adapter and each time I activate the woocommerce plugin the ‘Save Changes’ option in the adapter, Exchange Rates, Frontend Settings, and Cron Job is not selectable.

    #6553

    alexg
    Keymaster

    Yes, thank you for this! I can see the problem now. It has to do with CSS.

    I will fix it ASAP and will notify you again here.

    with regards

    #6555

    alexg
    Keymaster

    I have uploaded a patch version 2.1.1 to the WooCommerce Payment gateway to address this issue. Thanks again for your help!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.