Open extra topbar

Troubles connecting multi coin adapter to server

If you are new here, please see some information on how to ask for support. Thank you!

Troubles connecting multi coin adapter to server

dashed-slug.net Forums Full Node Multi Coin Adapter extension support Troubles connecting multi coin adapter to server

This topic contains 14 replies, has 3 voices, and was last updated by  alexg 6 months, 1 week ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #3990

    dollenick
    Participant

    Hi,

    I can not seem to find the right information to set up coins on a server and connecting them.
    Can you please help, I have been struggling with this adapter for a while now for a client.

    I have set up a bitcoin deamon, which crashes my site when I connect with it.
    But I don’t really need bitcoin, I need these coins KB3, xgox, opc,opcx monk,hold.

    Preferable just help with one of the coins and the deamon so I can do the rest myself.

    Thanks,

    Nick

    #3991

    dollenick
    Participant

    Alex if you read this, can you send me an email @ info@rankdata.nl

    I really could use your help!

    #3997

    alexg
    Keymaster

    Hello Nick,

    I would recommend that you first set up Bitcoin, even if you do not need it. This way you can get the feel of how this all works with a wallet that is known to work correctly. These smaller coins that you mention could have buggy wallets, so it’s best if you isolate for that case.

    Unfortunately, I do not undertake installations, as mentioned in the FAQ. However, I am able to help you with any specific questions you may have about installations.

    You mention that your site crashes when you try to connect to the wallet. Have you checked the Troubleshooting section of the main plugin for this? Please see “When I activate the plugin, my WordPress becomes extremely slow and is unusable.” If the plugin hits a firewall then it would cause timeout errors, therefore crashing the site. Also, check that your RPC credentials match those set in your .conf file.

    Please let me know how exactly connecting to the Bitcoin wallet crashes your site. Does the site become slow and/or unresponsive? Or does it show some error message? If there is an error message, please share it with me.

    thanks

    #4109

    dollenick
    Participant

    Hi Alex,

    Sorry for my late response, I could still use your help.
    The site crashes now everytime I activate the plugin. I tried uninstalling it and deleting all files but it keeps crashes the site into a 500 error.
    I cannot seem to get a error log too. I had setup the settings correctly in the config file as well as in the plugin.
    I cannot find similar problems in the faq or comment section.

    Thanks in advance!

    #4110

    alexg
    Keymaster

    Hello Nick,

    Could you please tell me the following:

    1. Did the plugin crash right after installation? Or did you first use a coin adapter? Which coin adapter did you use? Did you connect it to a wallet?

    2. You mentioned that you could not get the debug log. Have you enabled logging? https://codex.wordpress.org/Debugging_in_WordPress If there is an error 500 there should almost always be an error in your logs.

    Without knowing what the error is it is hard for me to tell you anything more.

    Looking forward to your reply.

    kind regards

    #4123

    dollenick
    Participant

    Hi Ales,

    Strangely my debug log does not show any sign of having troubles with the plugin.
    I have attached the debug log, maybe you know what you are looking for.
    It does not even register problems today at 23 of august even when the site crashes when i activate the plugin.

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at service@webmailer.de to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Hope to hear from you.

    Best regards,

    Nick

    #4124

    dollenick
    Participant

    1 more thing Alex,

    the problem (plugin crash) started when I entered the server adres and rpc user etc.
    Could it be a problem/ bug in the plugin? Or a firewall problem perhaps?

    Best regards

    #4125

    megeanwasson
    Participant

    Hey dollenick, if you are using cpanel hosting then maybe it is modsecurity that is causing the issue, so if that is the hosting platform they usually have a setting you can use to disable it.
    If you not on cpanel and on some other platform then ask the host if they have modsec running and to disable it for you to test if that was the problem 🙂
    This is only a suggestion to look at if you on cpanel.
    Regards
    Megan

    #4127

    alexg
    Keymaster

    @dollenick Since the problem occurs at the moment you enter the ip and port info, it is almost definitely an issue with some firewall.

    @megeanwasson Thank you for your comment. If you have had success with disabling mod_security then it’s worth a try, at least as a test. Although I would look into somehow allowing the RPC connection only, rather than disable mod_security altogether. I will look into that.

    #4290

    dollenick
    Participant

    Thank you Alex and megan,

    Unfortunately it is not running on cpanel so I cannot disable it easily.
    I am looking into the firewall to see if I can get it to work.

    @alexg Is it possible to have the plugin not crash the website everytime I enter an ip adress and port.
    It is pretty timewasting to disable the plugin and delete it everytime it crashes the site…

    Thanks!

    #4292

    alexg
    Keymaster

    Unfortunately, no! 🙂

    It would be best if you tested your connectivity from the Linux shell first, perhaps using nc. These crashes are caused by firewalls. Start by checking your rpcallowip setting and go from there…

    #4295

    dollenick
    Participant

    I have disabled the firewall temporarely to see if that works.
    The site does not crash, which is good 🙂

    I do get this error tho :
    ❎ Not responding: Dashed_Slug_Wallets_Coin_Adapter_RPC->get_balance() failed with status=”0″ and error=”Failed to connect to
    81.169.xx.xxxxx port 8332: Connection refused”

    #4307

    alexg
    Keymaster

    You should check:

    1. Your rpcallowip= statement.

    2. Your rpcuser= and rpcpassword= statements, or alternatively, your rpcauth= statement. These should match the credentials you are using to connect.

    #4380

    dollenick
    Participant

    Hi Alex,

    Thank you for the reply.
    I have just copied the settings stated in the adapter, those settings should be correct right?

    I have tried adding the ip manually well but it seems not to connect correctly.

    #4381

    alexg
    Keymaster

    Hello,

    Connection refused means that yhe plugin still can’t connect to your TCP port, so this is not a problem with IP filtering or authentication. Once you get an HTTP error response (such as 403 or 401) you will know that at least connection has succeeded. All I can tell you is that there must still be some firewall in place that’s blocking incoming connections to your wallet server on this port. It might be worth checking with your hosting provider If unsure.

    Please let me know if you encounter more problems.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.