Open extra topbar

There seems to be a problem with the deposit.

If you are new here, please see some information on how to ask for support. Thank you!

There seems to be a problem with the deposit.

dashed-slug.net Forums CoinPayments.net Coin Adapter extension support There seems to be a problem with the deposit.

Tagged: ,

This topic contains 16 replies, has 3 voices, and was last updated by  alexg 7 months, 2 weeks ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #4622

    vorticism
    Participant

    The deposit is currently failing.
    The address is displayed normally. There seems to be no problem with api key.
    Sent Successfully: No ‘is displayed on the deposit transaction of the IPN history.
    (IPN Date: status_text = ‘Deposit confirmed’)

    All deposit transactions are failing.
    Coinpayment balance is recognized in the balance. However, the balance does not increase for plugin users.
    withdraw works.

    #4625

    alexg
    Keymaster

    OK, this is definitely due to the IPN messages failing. Have you checked Wordfence? Any new plugins/servers/firewalls, etc?

    #4732

    jzntech
    Participant

    I have same issue – user has deposited coins to its generated adress with us – transaction history shows the deposit on coinpayments – the coins are added to our main wallet ( can be showed in the cold storage (online wallet balance) – but the user newer receives it in their account.

    I have wordfence installed and working smoothly – have installed a couple plugins that is not related to your plugin – ( i installed flamingo and contactform 7)

    Please advise – wallet shows ZERO for user.

    kind regards

    #4739

    alexg
    Keymaster

    @jzntech Hello, this is the most common problem people face at first when installing the CoinPayments adapter. Most likely some firewall is blocking your incoming IPN notifications.

    1. Have you checked the troubleshooting section, under “Deposits come through to the CoinPayments platform but do not show up in the plugin.”?

    2. Also, are you encountering this problem on a new installation, or did deposits work before?

    Please let me know

    with regards

    #4741

    jzntech
    Participant

    Hello Alex

    Deposits worked up until 1 oct…. the changes i made was to install exchange plugin, wordfence ( now deactivated to test ) …

    Have gone through Defender pro wpmudev plugin (deactivated for test) – allowed all connections from coinpayments on firewall —

    and still no deposits are showed up on wallets (showed in cold storage on coinpayments tough) ….
    checked ipn´s – they are retried and refused –

    Im stuck on where to trouble shoot – all connections are on allowed … have entered credentials 2 times now – lowered http chache to 60 sec instead of 180…

    Would be grateful for fast help…

    #4742

    alexg
    Keymaster

    Hello,

    The first step to debug this would be to log on to coinpayments.net and go to IPN history.

    See if the messages are delivered. They are probably not being delivered.

    Click on the date/time of a failed IPN message and see the details. There should be some information there as to why the messages are not being delivered.

    Besides wordfence, there can be other reasons why the incoming messages are not reaching your site. Possibly some firewall.

    Please let me know what you found in your IPN message history.

    with regards

    #4743

    jzntech
    Participant

    Hiya alex

    check pdf file ….

    Attachments:
    You must be logged in to view attached files.
    #4745

    alexg
    Keymaster

    Thank you for showing me the details. This is definitely some firewall.

    Remember there can be several firewalls in place, and your hosting provider might know something more about this.

    Ultimately you must find out why https requests to that URI are not passing through.

    best of luck

    #4751

    jzntech
    Participant

    DOing troubleshooting now with hosting .-… same issue…

    #4752

    jzntech
    Participant

    i get a error now where the public keys are

    IPN debugging
    Last IPN error:
    IPN Mode is not HMAC
    Local time of last error:
    2018-10-08 14:31:36

    ??

    #4753

    jzntech
    Participant

    Do you know what ip coinpayments is using to send their call to the script ? .. so we can identify the ip in the firewall logs ?

    #4754

    alexg
    Keymaster

    The error ‘IPN Mode is not HMAC’ would show if you attempt to visit the IPN URL from your browser. This is normal. The IPN URL should be accessed from the CoinPayments platform and the request should signed with a signature to verify authenticity.

    IPN requests usually come from 149.56.241.110.

    #4755

    jzntech
    Participant

    definitely a error on just that site..

    Tried same plugins on different site on same server different api keys … no error ….

    Tried same fresh api keys on old site (with error) … same error – “though shall not pass” kind of style 😉 ….

    conclusion… not firewall issue (becuase working site is on same account and same server ) … have to search within the plugins then…

    #4757

    jzntech
    Participant

    All security plugins deactivated . – no firewall – reduced all plugins besides wallet …

    Still same issue …

    No way to troubleshoot the IPN history either besides the history that dosent” say to much . – what ip adress is it coming from – what adress is it going to ..(https://superdomainname.com?wallets-cp-ipn=1)

    This is annoying … dont want to reinstall the plugins…

    Any ideas ? .. can we hire someone who is more knowledgeable than us on this matter ? … spent a couple days now on trouble shooting… all other dashed plugins deactivated… no wordfence or no security …

    Kind regards..

    #4759

    alexg
    Keymaster

    Hello again,

    This looks like it is a matter of networking if IPN messages are not being delivered.

    I would start by thinking what is different on those other sites where deposits work:

    1. Are you using a different CoinPayments account? Then it could be something to do with the account settings. If you follow this guide then everything should be in order. Make sure to not specify a custom IPN URL.

    2. Do you have a different web server config? Since you mention that other sites on the same server work, I would also compare the web server config of those other sites with the one that causes problems. Perhaps it is due to some rewrite rule. Do you see the incoming IPN in your server’s access log or error log? There could be indications towards the problem there.

    Unfortunately I am not available for hire, as explained in the FAQ. Also, it is likely that the problem is not within WordPress or its plugins, so I wouldn’t be able to help you anyway. This is probably due to some server configuration.

    Ultimately there is an incoming connection to your server. It either stops at your hosts firewalls, or your server’s firewall, or it reaches your web server, in which case it is stopped by your rewrite rules, or it is stopped at WordPress. There are logs for all of these layers. I would recommend that you start from the first one and determine at which point the message stops.

    with regards

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.