Open extra topbar

Server Error: Failed to connect: Connection refused

I reply to all queries on the forums and via email, once per day, Monday to Friday (not weekends).

If you are new here, please see some information on how to ask for support. Thank you!

Server Error: Failed to connect: Connection refused

dashed-slug.net Forums General discussion Server Error: Failed to connect: Connection refused

Tagged: , , ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #12603
    vingg
    Participant

    I was trying to put a PIVX wallet on my website and this happens.

    Not responding: Dashed_Slug_Wallets_Coin_Adapter_RPC->get_balance() failed with status=”0″ and error=”Failed to connect to 142.93.216.250 port 21092 after 1000 ms: Connection refused”

    I have already TCP incoming allowed, on the daemon VPS. But still I get this error.

    • This topic was modified 2 weeks, 3 days ago by alexg. Reason: more descriptive title
    #12605
    alexg
    Keymaster

    Hello,

    If you are certain that the TCP port is open on any software firewalls onyour VPS, you should also check:

    – If you have set the rpcbind config set correctly.
    – Check with your hosting provider, they are likely running their own firewalls. They can add an exception for you.

    Since you mentioned that you are on a VPS, know that during the IBD (Initial Blockchain Download), the wallet may use more resources (CPU, net) than you are allowed to use on a sliced host. In that case, your host may be auto-banned. Many hosts do this, depending on what rules they have. You may need to talk to them about this as well.

    with regards,
    Alex

    #12607
    vingg
    Participant

    Thanks for the fast response,

    I have moved to 6.0.0 because I cant make it to work.

    But same on 6.0.0 now I have attached some of the settings on my wallet.config

    and the error I am getting, hope you could help me sir.

    Attachments:
    You must be logged in to view attached files.
    #12611
    alexg
    Keymaster

    Hello,

    This makes sense. It’s good that you upgraded to 6.0.0, but this will not solve the network issue.

    Assuming that 162.0.217.62 is the IP of the WordPress host, add the rpcbind config line:

    rpcbind=162.0.217.62

    And restart the wallet.

    If it still doesn’t connect, then the issue is with some firewall, possibly one controlled by your hosting provider.

    with regards

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.