Open extra topbar

receive address not displayed

If you are new here, please see some information on how to ask for support. Thank you!

receive address not displayed

This topic contains 18 replies, has 2 voices, and was last updated by  pumpernickel 1 year ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #3288

    pumpernickel
    Participant

    Seems like everything is running and connecting.  But it is not displaying a deposit address although it seems to generate a barcode.

    #3290

    alexg
    Keymaster

    Hi can you please show me a screenshot?

    More importantly, are there any errors in your JavaScript console?

    Thanks

     

    #3292

    pumpernickel
    Participant

    It’s not letting me upload my screenshots.  I reduced the size to the point it’s not legible.

    I tried replying to the email, but its not going though saying invalid email address.

    But I get a javascript error on the client side with shortcodes

    GET http://scoobycoin.com/wp-content/plugins/wallets-multiadapter/assets/scripts/wallets-multiadapter-validator.min.js?ver=1.0.4 404 (Not Found)
    wallets-ko-3.5.0.min.js?ver=3.5.0:1 Uncaught TypeError: b.qrcode is not a function
    at c.updateQrCode (wallets-ko-3.5.0.min.js?ver=3.5.0:1)
    at Object.complete (wallets-ko-3.5.0.min.js?ver=3.5.0:1)
    at i (jquery.js?ver=1.12.4:2)
    at Object.fireWith (jquery.js?ver=1.12.4:2)
    at y (jquery.js?ver=1.12.4:4)
    at XMLHttpRequest.c (jquery.js?ver=1.12.4:4)

     

    but no error appears on the admin side when I try to deposit into cold wallets.

    But either way, it does not display an address.

    Thanks for your help.

    #3293

    alexg
    Keymaster

    Thanks for yuor reply.

    From the errors you reported it is clear that some of the frontend scripts are not loaded.

    The frontend script for the address validator is not loaded, and the JQuery qrcode script seems to be missing too. This would explain your issues. Some thoughts that come to mind:

    Could it be some problem with a CDN you use?

    Or a misconfiguration of your web server? Try to determine why the assets would not load.

    Is this a new installation? Did you change something on your server recently? Does the plugin work when you disable other plugins?

     

    #3294

    alexg
    Keymaster

    The link http://scoobycoin.com/wp-content/plugins/wallets-multiadapter/assets/scripts/wallets-multiadapter-validator.min.js?ver=1.0.4 returns 404 which normally means that the script is not on your server. Could it be that the file is missing from your server directory?

     

    #3308

    pumpernickel
    Participant

    Looks like there isn’t a wallets-multiadapter directory.
    But there is a multiadapter-validator.min.js under the Bitcoin_and_altcoin_wallets__full_node_multi_coin_adapter_extension-1.0.4-wordpress-plugin-3d16976/assets/scripts directory

    #3309

    alexg
    Keymaster

    Hello,

    It seems you have not installed the plugin extension correctly. You have extracted the zip file into the plugins directory, retaining the filename as a directory name.

    Delete the plugin directory, then go to Plugins -> Add new -> Upload plugin and select the plugin’s zip file for upload.

    After this, activate the extension and it should be ready for configuration.

    kind regards

     

    #3313

    pumpernickel
    Participant

    Yes, I did install it that way.

    I renamed my plugin directory and started over.

    But I am still getting the same result without any error.

    It generates a bar code but no address.

    #3334

    alexg
    Keymaster

    OK you have now presumably installed correctly, and activated, the multiadapter extension. Can you please tell me the following:

    1. You previously reported an error about the qrcode library not being loaded. Do you still get that error?

    2. What do you get when you type the following in your console? typeof jQuery.fn.qrcode

    3. Do you see any errors now in your JavaScript console?

    4. Could it be that you have done the same installation mistake with the main plugin? The main plugin should be installed either by uploading the zip file via the “upload plugin” button or directly from wordpress.org via the admin interface. (You could unzip the plugin manually, but in that case you need to make sure that the directory is named “wallets” and that the file permissions and user ownership match those needed by your web server.)

    Let me know.

    #3374

    pumpernickel
    Participant

    Hi there,

    1) no error being reported

    2) it responds with “function”

    3) still no errors

    4)yes, this was installed via the upload plugins page.

    5) please check out the test page with all of the wallet links in it.

    test

    I am having difficulty attaching a screenshot or replying to the email.

    Thanks.

    #3376

    alexg
    Keymaster

    Thank you for the additional info. I signed up to your site and had a look at the test page.

    As you said, there are no JavaScript errors.

    The JSON API does not report a deposit address. This is why it is not shown. When logged in, you can see the response yourself. There is a missing field,deposit_address: https://scoobycoin.com/test/?__wallets_apiversion=2&__wallets_action=get_coins_info

    The JSON API code uses the wallets_api_deposit_address filter to get the user’s deposit address: https://wallets-phpdoc.dashed-slug.net/classes/Dashed_Slug_Wallets_PHP_API.html#method_api_deposit_address_filter

    If an address is not already assigned to the user, a new address is generated by the wallet via the getnewaddress RPC command. Then, the address is attached to the JSON API response, like so:

    https://github.com/dashed-slug/wallets/blob/3.5.4/includes/json-api.php#L612-L618

    1. Is it possible that your wallet does not respond to the getnewaddress RPC command? Can you call the command from the CLI to check yourself? For Bitcoin, you would do a bitcoin-cli getnewaddress and it would respond with a string that is a new address. You should replace bitcoin-cli with the name of your wallet’s binary.

    2. If the RPC command works as expected, it might be worth looking at your PHP logs. You can enable WordPress logging and then look at wp-contend/debug.log. Then, check to see if any errors appear while the plugin requests a new address.

    Please let me know.

    kind regards

    #3377

    alexg
    Keymaster

    After doing some more investigation:

    You coin’s symbol is SCOOBY. This is 6 characters long and the current DB schema for this plugin allows up to 5 character symbols.

    https://github.com/dashed-slug/wallets/blob/master/includes/wallets-core.php#L284
    https://github.com/dashed-slug/wallets/blob/master/includes/wallets-core.php#L308

    Can you try with SCOOB? It should work.

    I might increase this limit in the next schema upgrade.

    kind regards

    #3453

    pumpernickel
    Participant

    Yes, I really need this fixed in the next upgrade.

    I will have no choice but to wait.  As it does not make sense to change the ticker on the main site for this coin.

    The ticker should be SCOOBY.

    Although I am a paying subscription member, I am willing to give you some scoobycoins for this upgrade.

    Thanks!

    #3465

    alexg
    Keymaster

    Hello,

    I will fix this on the next release. The change will require a schema upgrade and will allow up to 8 characters for symbols. This should be sufficient for any coin.

    Thank you very much for your membership. I do not require payment for the change. If you wish to donate to the project you are always welcome to do so.

    The standard donation addresses are:

    Bitcoin Address: 1DaShEDyeAwEc4snWq14hz5EBQXeHrVBxy
    DOGE Address: DASHEDj9RrTzQoJvP3WC48cFzUerKcYxHc
    LTC Address: LdaShEdER2UuhMPvv33ttDPu89mVgu4Arf

    Or you can donate SCOOBY to SMbCzz6R1k2aGTYanbLZfy5tCcz1DaZP9v if you wish.

    #3627

    alexg
    Keymaster

    Hello,

    The schema upgrade is now rolled out in the 3.5.6 release. You can use coin symbols of up to 8 characters.

    kind regards

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.