Open extra topbar

Permissions problem?

I reply to all queries on the forums and via email, once per day, Monday to Friday (not weekends).

If you are new here, please see some information on how to ask for support. Thank you!

Permissions problem?

dashed-slug.net Forums General discussion Permissions problem?

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #3813
    clickforafrica
    Participant

    Hi, I cannot get into the settings for the bitcoin and altcoin wallets plug-in. I tried disabling all other plugins, and disabling the child theme. Still “wallets” doesn’t appear in the side menu, and when I try to access it via “wallets” in the plug-in page, it says I am “not allowed to access this page”.

    It’s only happening on one site, the other two are fine. All are fully up-to-date i.e. no updates showing as pending.

    Any help appreciated.
    Thanks
    Andy

    [edit] Nothing is showing where the shortcodes are in the user pages either.

    #3824
    alexg
    Keymaster

    Hello,

    Does your admin user have the manage_wallets capability? It sounds like not.

    You can use any third-party plugin that manages roles and capabilities to assign manage_wallets to your user.

    This should solve your problem, but please tell me if it does not.

    kind regards

    #3992
    clickforafrica
    Participant

    Hi thanks for the advice. I checked and Admin user does have manage_wallets. I checked the activation code and that is correct. I’ll go back to an old back-up and see if that helps.
    https://postimg.cc/image/rbgib6mtl/

    #3998
    alexg
    Keymaster

    1. Is your site a multisite? If so, AND if the plugin is network-activated, then you will find the wallets sub-menu under the network admin menu, not the site-level menu.

    2. If the above is not the case, then I’m not sure why this would happen. Could you try disabling other plugins, or possibly switch to another theme to see if that helps?

    3. Do you see any errors in your WordPress debug log? You would first have to enable logging: https://codex.wordpress.org/Debugging_in_WordPress

    I could also login to your site to have a look if you like.

    kind regards

    #4142
    clickforafrica
    Participant

    HI, satoshihost.com should have sent you an email with registration. It’s low priority, I have to do the other sites first so no rush.

    I still can’t figure out what’s different. It’s not multi-site. I have trouble enabling debugging, it’s a geeky process for me and has never worked properly. They should just have a simple on/off button!
    Cheers
    Andy

    #4149
    alexg
    Keymaster

    Hi Andy,

    I logged in to your site and, after deactivating some plugins, I found out that the Wallets menu is shown when I deactivated the “Members” plugin.

    I will now investigate why this is the case, and will let you know here once I do.

    kind regards

    #4150
    clickforafrica
    Participant

    Hi, sorry, I should have spotted that.

    #4151
    alexg
    Keymaster

    I have determined that, on my home computer, there is no problem with installing “Members” and “Bitcoin and Altcoin Wallets” at the same time. However:

    It seems that on your site, the plugin “Members” cannot be activated unless you first deactivate “WPFront User Role Editor”Both of these two plugins try to declare a function with the same name, members_get_capabilities(). “Members”, if installed first, does not check if the function is declared. The error message is:

    Fatal error: Cannot redeclare members_get_capabilities() (previously declared in /home/satoshihost/public_html/wp-content/plugins/wpfront-user-role-editor/classes/class-wpfront-user-role-editor.php:211) in /home/satoshihost/public_html/wp-content/plugins/members/inc/functions-capabilities.php on line 306

    This is a problem with “Members”, not with the other plugin.

    As I am unable to reproduce the problem with Bitcoin and Altcoin Wallets, I strongly recommend that you try again to enable WordPress debugging. It is not very hard, you simply need to edit the wp-config.php file as explained here. You need to add define( 'WP_DEBUG', true );, define( 'WP_DEBUG_LOG', true );, and define( 'WP_DEBUG_DISPLAY', false );. There are good reasons why this cannot be a simple on/off button.

    There are two ways to proceed:

    1. If you can enable the log file, then there will be some error messages written out to the logs. Then I can get a better idea of what is going on.

    2. If I had to guess, this particular plugin does something with capabilities that messes with the manage_wallets capability at runtime. If you are OK with using some other membership plugin then you should be OK.

    kind regards

    #4154
    clickforafrica
    Participant

    Thanks, I think I have enabled debugging, but nothing shows in the interface. I followed the instruction on your link.
    here is the part of the wp-config.php:

     // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings 
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define( 'SCRIPT_DEBUG', true );
    
    /* That's all, stop editing! Happy blogging. */

    I re-enabled members and the role editor, but so far no debug.log has appeared in wp-content. Is there something else I need to do?

    #4174
    alexg
    Keymaster

    No, this is all you need to do.

    Once there is an error, the debug.log file will be written.

    Please let me know if you find anything.

    In the meantime I am testing the Members plugin more extensively to see how it could cause this problem. I have yet been unable to reproduce the problem.

    with regards

    #4711
    clickforafrica
    Participant

    Hi again, I re-installed WP and restored a backup from earlier. It’s all working now. I think the role editor is not needed, I just added two roles, and they remain after removing the plug-in, so it probably won’t cause any more trouble.
    Thansk a lot.

    #4714
    alexg
    Keymaster

    Thank you very much for reporting your findings.

    Yes, the role editor is useful only if you need to edit roles, otherwise the roles you have will remain as they are even without the plugin.

    Glad to hear that you got it working!

    regards

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.