Open extra topbar

Not all coins show exchange rates on shortcodes

If you are new here, please see some information on how to ask for support. Thank you!

Not all coins show exchange rates on shortcodes

dashed-slug.net Forums General discussion Not all coins show exchange rates on shortcodes

This topic contains 5 replies, has 2 voices, and was last updated by  alexg 10 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #5658

    megeanwasson
    Participant

    Hi Alex, Great work on the latest updates 🙂

    I am having an issue on the frontend not showing all coins exchange rates and fiat values.
    In the backend at exchange rates I can see the coins are there and showing their respective exchange rates.
    On the front end only few of the coins actually show their rates.
    Coin wallets are all responding, deposits withdrawals etc all work as expected, just the exchange rates that are not showing for all coins.
    See screenshots:
    rapids-rpd-coin-exchange-rates-admin.jpg

    rapids-rpd-coin-exchange-rates-front-end

    rapids-rpd-coin-exchange-rates-wallet-front-end

    This was from before the update, I did not report as I was hoping maybe update would fix the issue.
    Any assistance advice debugging steps will be appreciated.

    Kind Regards
    Megan

    #5663

    alexg
    Keymaster

    Hello Megan,

    I believe that the issue with your coin is that its price is so low that its USD value is rounding to zero. This is something that I will need to fix in the code.

    1. Could you please verify that the missing coins all have small unit value? What happens if you attempt to withdraw 1000000000 Rapidscoin? Does the withdrawal form show any USD price then?

    2. In your browser’s JavaScript console, what is the result of: wp.wallets.viewModels.wallets.coins()['RPD'].rate ?

    thank you

    #5670

    megeanwasson
    Participant

    Hi Alex,
    Thank you as always for your quick response 🙂
    I am not able to withdraw RPD amount as I do not have many coins, withdraw form just says insufficient funds.

    Result of
    wp.wallets.viewModels.wallets.coins()['RPD'].rate
    error-images.btcpacks.org/rapids-java-console-query1

    #5672

    alexg
    Keymaster

    Interesting.

    I am not suggesting that you actually withdraw the coins, simply enter the number. The idea was to look to see if the USD amount is printed below.

    However it seems that the RPD coin is not available in the frontend at all. Check the JSON API with: https://example.com/?__wallets_apiversion=3&__wallets_action=get_coins_info, replacing example.com with your domain. Is RPD in the response? If not:

    1. Go to “Wallets” -> “Frontend settings” -> “Disable transients (debug)” and check the option. Does it make a difference? Afterwards, uncheck the option again.

    2. Clear your server’s cache. Does the JSON API report your coin now?

    Hope this helps. Let me know please if you find something.

    #5677

    megeanwasson
    Participant

    Hi Alex,
    No it does not show fiat amount when entering 10000000000

    error-images.btcpacks.org/rapids-withdraw-enter-to-check-fiat-value

    On the API call it does show all the coins.
    I did notice however it does show that Rapids is_crypto FALSE, same with DACASH shows is_crypto FALSE see screenshot, This then made me look at the wallets-alt-coins-adapter.php which has all the coins info in.

    	$coins['RAPIDS'] = array(
    		// Coin symbol
    		'symbol' => 'RPD',
    		// Coin name
    		'name' => 'Rapidscoin',
    		// Default withdrawal fee (coin adapter settings override this)
    		'wd fee' => '0.005',
    		// Default internal transaction fee (coin adapter settings override this)
    		'move fee' => '0.0005',
    		// Default min confirmation count required for deposits (coin adapter settings override this)
    		'confirms' => 12,
    		// Default RPC port (coin adapter settings override this)
    		'port number' => 12345,
    		// Whether the wallet supports -walletnotify
    		'tx notify' => 1,
    		// Whether the wallet supports -blocknotify
    		'block notify' => 1,
    		// Whether the wallet supports -alertnotify (some wallets have deprecated this)
    		'alert notify' => 0,
    		// Comma separated list of hex bytes, needed for frontend validation of withdraw addresses. Leave blank for no validation.
    		'versions' => '0x61,0x61',
    		// An sprintf() pattern for deposit address QR Code URI. If unsure, set to '%s'.
    		'qr pattern' => 'rapidscoin:%s',
    		// An sprintf() pattern for displaying amounts. If unsure, leave to '%01.8f'.
    		'amount pattern' => '%01.8f',
    		// Default sprintf() pattern for URI to block explorer transaction page. Can be overriden with WordPress filter.
    		'explorer tx uri' => 'http://209.97.188.183/tx/%s/',
    		// Default sprintf() pattern for URI to block explorer address page. Can be overriden with WordPress filter.
    		'explorer address uri' => 'http://209.97.188.183/address/%s/',
    		// URL to an 64x64 icon for the coin. Or leave empty to pull the icon from 'assets/sprites/SYMBOL.png'.
    		
    	);
    

    I have now changed the coins name to the symbol name now all works fine 🙂
    $coins['RAPIDS'] = array( <---- seems to be the problem

    rapids-api-query-with-is_crypto-result-false

    Thank you for helping me find this error.
    Maybe on the explanation on using the altcoins plugin mention to users to name everything correctly 🙂
    $coins['YOURCOINSYMBOLNAME'] = array( <-----

    Hopefully this helps anyone else with the same problem.
    Thank you again for your assistance to getting this resolved my end 🙂
    Kind Regards
    Megan

    #5679

    alexg
    Keymaster

    Yes, the coin’s index in the array must be the coin’s symbol.

    I have made the instructions clearer now.

    Thank you!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.