Open extra topbar

No address generated in BTC core node

If you are new here, please see some information on how to ask for support. Thank you!

No address generated in BTC core node

dashed-slug.net Forums Full Node Multi Coin Adapter extension support No address generated in BTC core node

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #7959
    deutsche-emark
    Participant

    For some days I play around with the exchange plugin. Now I have some problems.

    1. it was difficult to connect the bitcoind from a remote server. The website is hosted and the wallets are at my home. Litecoin and eMark work perfectly but BTC didn’t want to connect. I have to insert the IPv6 IP then the Adapter was responding.

    2. I cannot create a BTC Address. If I click “Create deposit addresses now for all users” or “Renew deposit addresses” existing Users don’t become a BTC Address. I have created a new user, the same. No BTC Address only LTC and DEM.

    I use bitcoind 0.19.9
    I have found this:
    Bitcoin Core 19.1.0.1 defaults generating Bech32 receive addresses (prefixed with “bc1”)
    Is this the problem?

    Thanks

    #7961
    alexg
    Keymaster

    Hello,

    1. I am not sure why only IPv6 worked. In any case running your wallets on a home machine is tricky. If it works now, then that means that you’ve set up NAT forwarding correctly. Don’t forget to put your machine and modem on a UPS for maximum uptime. Also, you’ll need a static IP for this to work. If your residential modem restarts or reconnects and you have a dynamic IP, it will be different each time.

    2. The “Renew deposit addresses” feature simply marks all deposit addresses as “old”. Next time the user logs in to the frontend they will be assigned a new deposit address. I am not sure why this happens but I will test with the latest Bitcoin core and will report back. In the meantime you can check your wallet’s log file, or enable WordPress logging and check the debug log for any problems. If there is an issue it will show up when you call the get_coins_info endpoint: (https://www.example.com/?__wallets_apiversion=3&__wallets_action=get_coins_info)

    There shouldn’t be any problem with bech32 addresses as far as the plugin is concerned. If you want to force your wallet to generate another type of address, you can set addresstype in your conf file. Consult bitcoin-cli help getnewaddress for details.

    I will test with 0.19.1 and get back to you.

    with regards

    #7967
    alexg
    Keymaster

    Hello,

    I have now built and tested the plugin with Bitcoin 0.19.1. I have not spotted any issues with generating new addresses.

    You mentioned that you tested 0.19.9 which is not out yet, I’m guessing you meant 0.19.1.

    Please let me know if you spot any issues in your logs while attempting to generate new addresses.

    Also, it would be helpful to look into the database. Can you execute the following query?

    select status,count(*) from wp_wallets_adds where symbol='BTC' and account=1 group by status;

    This would show you how many BTC deposit addresses for the admin user are marked “current” and how many “old”. After hitting “Wallets” -> “Adapters” -> “Renew deposit addresses” all the addresses should be marked “old”, meaning that calling get_coins_info would then create new addresses. Again, if there is a problem this would probably show in the WordPress debug log (wp-content/debug.log) or bitcoin log (~/.bitcoin/debug.log).

    Please let me know if you find anything of interest. I will continue to look for a situation where this issue could arise.

    with regards

    #7968
    deutsche-emark
    Participant

    Thanks for the answer.
    I have static IP 5.146.4.167
    After some testings around I have figured out that if I use the IPv6, the adapter is responding but the padlock is closed. I’m unable to open the padlock and no address is generated.
    Now I have disabled the IPv6 in the Router and restart the server. Now I have only IPv4. But the BTC Wallet adapter is not connecting to my Bitcoind.
    Then I have installed the newest Dogecoind on my server. I see, that there are the same problems as Bitcoin. No remote connection under IPv4, responding under IPv6 but padlock closed.
    The wp error log cannot help. There are errors like “Failed to connect to 5.146.4.167 port 8332: Connection refused” or “Could not get info about coin with symbol BTC: Adapter for “BTC” did not respond to the getnewaddress RPC command with a valid address string.”
    Other Coins like Litecoin, Feathercoin or eMark running fine.

    #7969
    alexg
    Keymaster

    Hello,

    Actually the error message you found is very helpful. It means that the plugin cannot contact your wallet.

    Reasons for this can be:

    1. the rpcallowip= line in your conf. You probably have something like rpcallowip=5.146.4.167/24 in your conf. But if you’ve set up NAT then connections should be coming from your modem/router. Try adding something like rpcallowip=192.168.0.1/8, assuming this is the IP of your router. Whatever you do make sure to use CIDR notation (i.e. include a netmask as shown above)

    2. NAT configuration. Double check the port forwarding rules in your router. You want port 8332 to be forwarded to your local network address.

    Hope this helps.

    with regards

    #8128
    deutsche-emark
    Participant

    Hi Alex,
    first, I must say that your plugin work perfectly. This was not a problem with the adapter, this was a Problem with VirtualBox where the wallets run.
    Here is the solution why i cannot get an IPv4 :

  • https://superuser.com/questions/1146122/ubuntu-virtualbox-guest-does-not-get-ipv4-in-bridged-mode
  • “In the Settings for the VirtualBox VM, go to Network and then drop down the Advanced settings in the right-hand pane and check the “Adapter Type.” The default appears to be “Intel PRO/1000 MT Desktop (82540EM).” With that adapter type, I had the exact same problem, so I tried changing the Adapter Type to “Intel PRO/1000 MT Server (82545EM)” and then updating the /etc/network/interfaces file (if you change the adapter type before you install Ubuntu Server it should create the interfaces file with the correct info) and it now works fine. The version of VBox I’m using is 5.1.28 r117968 (Qt5.6.2) on a Windows 10 host and using Bridged networking.”

#8135
alexg
Keymaster

Hello,

I’m glad you figured it out!

Thank you very much for providing this detailed follow-up.

with regards

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.