I reply to all queries on the forums and via email, once per day, Monday to Friday (not weekends).

If you are new here, please see some information on how to ask for support. Thank you!

Moved: Error 524

dashed-slug.net Forums General discussion Moved: Error 524

Tagged: , ,

  • This topic has 15 replies, 3 voices, and was last updated 5 years ago by Anonymous.
Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
  • #5153

    Hello Alex, thank you as always for this extraordinary work.
    Lately I am suffering an anomaly in my server that I solve when I deactivate your plugin. I’m not sure it can be exactly, but I solve it by deactivating the plugin or restarting the php-fpm service.
    The problem is that my website is slowing down until it runs out of resources throwing me an error 524.
    Looking to consume the resources with the top tool, I see that there are many processes of pool-website.com.
    I’ve thought about disabling cron tasks but I’m not sure how to implement it in wordpress outside of cpanel.
    The fact is that I have two facilities, identical, one with woocommerce adapter and another simple one.
    I’m noticing this since the last update of woocommerce, and it is possible that there is some incompatibility, or I do not know, I’m a little desperate to find the problem and return to normal, since my site is blocked every hour.
    Could you tell me what command should I enter in cron to do a test?
    By the way, also with wp-control I get this error: cURL error 28: Operation timed out after 3003 milliseconds with 0 bytes received ”

    Thanks in advance. A greeting.



    First of all I have moved your post to a new thread.

    Before doing anything we must determine what is causing the problem:

    1. Which coin adapter are you using?

    2. Which plugins and extensions are you using?

    3. Are you able to login and use the site? Under what circumstances do you get error 524?

    4. If you can login, try disabling cron jobs (set Run every to never). Does the problem resolve itself? If not, then the issue is not related to cron jobs.

    5. Does the problem resolve itself if you disable other plugins?

    6. What happens if you deactivate the woocommerce payment gateway? Does the site become responsive?

    7. Also, HTTP 524 is the timeout error code. This indicates a firewall problem. Did you reconfigure your webserver in any way, or did you move between hosts?

    8. Are you using cloudflare? Could you disable it for a moment to see what happens?

    Please let me know about all of the above so I can get a clearer picture.

    with regards


    I have disconnected the cron in “never” as you said, and the system seems to be stable, at the moment it went correctly.
    I would like to try adding the tasks to the cpanel, to see if it works correctly as well or else it hangs up as well.
    What is the command that I should put in addition to the execution time? I have a warning on the control panel with a url, but when I put it in the cron it tells me that there is an error.
    this is the url https://mydomain.com/?__wallets_action=do_cron&__wallets_apiversion=3&__wallets_cron_nonce=0227e9c5029dxxxxxxxxxxxxx How should I place this url in the cpanel cron?


    Assuming that curl is in /usr/bin on your system, you could add the following command:

    /usr/bin/curl -sk https://mydomain.com/?__wallets_action=do_cron&__wallets_apiversion=3&__wallets_cron_nonce=0227e9c5029dxxxxxxxxxxxxx > /dev null 2>&1

    The full crontab entry for running this every five minutes would be:

    */5 * * * * /usr/bin/curl -sk https://mydomain.com/?__wallets_action=do_cron&__wallets_apiversion=3&__wallets_cron_nonce=0227e9c5029dxxxxxxxxxxxxx > /dev null 2>&1


    I have this error:
    /usr/local/cpanel/bin/jailshell: /dev: Is a directory
    {“result”:”error”,”code”:403,”message”:”Legacy JSON APIs are disabled on this system. Please use version 3 of the API in your requests, or contact the site administrator to enable legacy API endpoints.”}

    any solution?

    Thank you.



    My apologies, you should add quotes around the url since it contains ampersands. And I forgot to add a slash to /dev/null before. So the command should be:

    /usr/bin/curl -sk 'https://mydomain.com/?__wallets_action=do_cron&__wallets_apiversion=3&__wallets_cron_nonce=0227e9c5029dxxxxxxxxxxxxx' > /dev/null 2>&1

    Without a shell it is going to be hit-and-miss before you figure out the exact command since every system is different, but I think the above will work.

    Let me know if it doesn’t.


    Hello Alex, Happy Holidays:
    The system has stabilized for a while, but I have a last update and again the problem has returned.
    Now I have the cron from cpanel, but the server hangs up again and I get the error 524 after 30-60 minutes that I restart the php-fpm.

    maybe I can give you access codes by private to take a look?



    524 is the server timeout error and it is probably unrelated to the cron job. It is possible that this error is related to Cloudflare, if you are using it. Does the site work if you disable Cloudflare altogether?

    You can always contact me at my email and I can try to have a look.

    with regards


    Now the only thing that does not work are the withdrawals.

    I have tested with the worpress cron and with a cron task in the hosting and they process, they remain pending.


    Could you please try again with version 4.0.1, and let me know if the problem with withdrawals remains?

    Also, check that the adapters are unlocked in the adapters list view.

    thank you


    Hello Alex, greetings again. I come to you after a while trying other matters, but my site must be configured without cron.
    The moment I run the cron task one way or another, the site clogs and my apache crashes.
    this is what I found in the log.
    I see that the tasks start but do not continue.
    desaboilite completely the cloudflare. cache. and wordfender. but the problem is not removed.
    any ideas?
    [23-Mar-2019 22:46:09 UTC] Bitcoin and Altcoin Wallets transaction tasks STARTED. Elapsed: 0 sec, Mem delta: 584 bytes, Mem peak: 176437344 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [23-Mar-2019 22:46:09 UTC] Bitcoin and Altcoin Wallets fail transactions FINISHED. Elapsed: 0 sec, Mem delta: 11880 bytes, Mem peak: 176437344 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [23-Mar-2019 22:46:09 UTC] Bitcoin and Altcoin Wallets execute pending moves FINISHED. Elapsed: 0 sec, Mem delta: 156976 bytes, Mem peak: 176437344 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [23-Mar-2019 22:46:10 UTC] Bitcoin and Altcoin Wallets execute pending withdrawals FINISHED. Elapsed: 1 sec, Mem delta: 179728 bytes, Mem peak: 176437344 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [23-Mar-2019 22:46:10 UTC] Bitcoin and Altcoin Wallets ALL transaction tasks FINISHED. Elapsed: 1 sec, Mem delta: 179720 bytes, Mem peak: 176437344 bytes, PHP / WP mem limits: 512 MB / 512 MB
    [23-Mar-2019 22:46:10 UTC] Bitcoin and Altcoin Wallets cron jobs STARTED. Elapsed: 0 sec, Mem delta: 576 bytes, Mem peak: 176437344 bytes, PHP / WP mem limits: 512 MB / 512 MB



    To summarize the problem so far: When you run the cron job, your apache server crashes. If your server is very low on resources, then this could be expected, but otherwise the cause can be something else.

    1. If apache crashes, there must be some error written out to the apache logs. Can you check? It’s probably in /var/log/apache2/error.log, but your system might be different.

    2. Which coin adapter or adapters are you using?

    3. If there is more info in your logs after running a cron job, could you please send me the complete logs to my email?

    4. Are you still getting timeout errors (524?)

    Let me know please. thank you

    with regards


    I have sent you an email with the htaccess. I think the problem may come out there


    Your .htaccess file is huge. It will take some time to analyze and I am currently extremely busy. I will get back to you. It is likely that this is indeed the problem.

    In the meantime, you can try the recommended default for WordPress: https://codex.wordpress.org/htaccess

    I am not sure if something else will break when you replace all these rules, so keep a backup of your current .htaccess file.

    with regards


    Your .htaccess file seems to redirect correctly a cron URL trigger to the WordPress index.php.

    Could you please try to answer the other questions I posted earlier? Without this info, it’s impossible to know what went wrong.


Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.