Open extra topbar

If you are new here, please see some information on how to ask for support. Thank you!

Moved: deposit address not displayed

dashed-slug.net Forums Full Node Multi Coin Adapter extension support Moved: deposit address not displayed

This topic contains 24 replies, has 2 voices, and was last updated by  alexg 6 months ago.

Viewing 10 posts - 16 through 25 (of 25 total)
  • Author
    Posts
  • #5505

    alexg
    Keymaster

    Hello again,

    In addition to my previous post:

    I have located the github repo from your website, and have tested your wallet with the plugin. The plugin correctly shows deposit addresses beginning with the letter “D”.

    Since everything seems to work fine here, this means that you are probably facing some type of connectivity issue. Please respond to the points 1 to 3 above, and disregard #4.

    with regards

    P.S. In several places throughout your website, you ask for people to “undermine” your currency. I believe you want to ask them to mine it instead.

    #5507

    diners21
    Participant

    Hello, thanks for all the information.
    I have disabled the firewall but I still can not generate the addresses.

    I do not see anything in my records that says ADDRESS1, ADDRESS2, I attach screenshots so you can see.

    Attachments:
    You must be logged in to view attached files.
    #5510

    alexg
    Keymaster

    Thank you.

    To be clear, the information I am looking for would be in your WordPress debug log. The screenshots you sent me are the JSON API response, and the coin adapters screen. The adapter is indeed in a responding state, which is a good sign.

    So, if you have not already done so, please do the following:

    1. Enable debugging by adding to your wp-config.php:

    
    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    

    Then, visit the get_coins_info JSON API call again.

    Afterwards view the file wp-content/debug.log. The debug information will be in there. Look for the lines with the date/time that you performed the API call at.

    2. About the firewalls: There might be more than one types of firewalls/security programs on the WordPress server and the wallet server. You can disable them for testing, but do not keep them disabled. You should understand how they work and allow TCP connections outgoing from your WordPress server to your wallet server on port 44062. Are these on separate machines or on the same machine? If they are on the same machine, then it is not likely that a firewall is the problem.

    3. Finally, if you like, show me how you added your coin to the multi-coin adapter, as there might be some issue there.

    #5524

    diners21
    Participant

    Hello, if the wordpress server is on one machine, and the wallet on another machine.

    I have a question on the IP:

    Daemon RPC API
    The DINERS full node (multi) adapter needs to know the location and credentials to the RPC API of the DINERS daemon.

    IP
    46.26.13.13:44062
    The IP of the machine running your wallet daemon. Set to 127.0.0.1 if you are running the daemon on the same machine as WordPress.

    My Ip is 46.26.13.13, although I have 2 PCs, with two different portfolios of the same coin, I must put the IP as I have put it, or I should put the IP within my network, of the computer to which I want it to be connect?

    Thanks for your help.

    #5527

    diners21
    Participant

    In the debug.log I get this:

    Attachments:
    You must be logged in to view attached files.
    #5529

    diners21
    Participant

    And it would not be easier, if I could upload in any way, the Diners addresses, so that the script is choosing them for different users, is this possible?

    #5531

    alexg
    Keymaster

    Hello,

    Thanks for the logfile. Here’s my findings:

    1. The plugin does not receive any deposit addresses at all from the wallet.

    2. You have also installed the CoinPayments adapter, but you have not given all the permissions to your API key. Please check step #23 of the instructions and add the missing permissions.

    To answer your questions:

    The IP needs to be reachable from the machine where WordPress runs. You cannot easily use a home computer or other computer that is only reachable via NAT. Additionally, this is highly not recommended. You should use a server whose IP is reachable from the internet. If you need to check, use a tool such as http://www.canyouseeme.org/ to see if your wallet’s port is visible from the internet.

    The plugin pulls the deposit addresses from the wallet as needed. To do it any other way would simply confuse things. Also, it is likely that withdrawals will also not work until you resolve this issue.

    At this point I would recommend that you do the following:

    1. Make sure the wallet is running on a server with a public IP. You need to allow connections to the wallet. Check with a port checker tool as discussed above.

    2. Disable all unrelated plugins, including the CoinPayments adapter, and leave only wallets and the multi coin adapter. Then, try again.

    3. If the above fails, show me the code you used to add the coin to the multiadapter, AND the .conf file. Remove any passwords from the file before you send it to me but otherwise leave it intact. There might be a problem with your rpcallowip setting, or some other issue.

    Hope I have answered your questions.

    Let me know how it goes.

    with regards

    #5538

    diners21
    Participant

    Do everything you say, without success, the addresses continue without showing, the Ip is accessible: 46.26.13.13 and the port also: 44062, you can check yourself in the URL you provided.

    I send you information on how I have put the full node, and I attached the Diners.conf. Thanks for your help.

    Info full node:

    IP: 46.26.13.13:44062 (I’ve tested it by removing the: 44062 and putting it, no success in both)

    Port: 44062
    User: rpc_diners
    Password: xx
    SSLEnabled: Not activated
    Minimum confirmations: 1

    #5539

    diners21
    Participant

    I enclose the .conf info since it will not let me send it to you:

    rpcuser=rpc_diners
    rpcpassword=xx
    rpcallowip=127.0.0.1
    rpcallowip=31.22.4.221
    rpcport= 44062
    listen=1
    server=1
    daemon=1
    staking=1
    addnode=127.0.0.1
    addnode=94.19.97.15
    addnode=136.144.171.201
    addnode=46.26.13.13
    addnode=186.92.82.218
    addnode=179.187.33.238
    addnode=80.110.72.245
    addnode=45.76.92.111
    addnode=35.189.199.147
    addnode=212.237.37.46
    addnode=188.165.244.7
    addnode=203.111.176.3
    addnode=155.94.164.5
    addnode=150.129.80.244
    addnode=187.36.176.220
    addnode=203.205.30.171
    addnode=190.36.39.92
    addnode=186.92.127.155
    addnode=201.141.38.221
    addnode=190.199.204.6
    addnode=152.156.217.11
    addnode=178.93.240.191
    addnode=193.116.196.127
    addnode=51.254.197.178
    addnode=191.33.64.205
    addnode=217.115.122.221
    addnode=180.254.41.114
    addnode=35.189.199-147
    walletnotify=curl -sk https://www.diners.ltda/wallets/api3/notify/DNS/wallet/%s>/dev/null
    blocknotify=curl -sk https://www.diners.ltda/wallets/api3/notify/DNS/block/%s>/dev/null

    #5543

    alexg
    Keymaster

    Hello,

    You are correct, the port is open.

    There are some minor errors in your .conf but nothing that would explain your situation.

    When entering the IP address in the coin adapter settings, you should not enter the port number with the colon : notation. Instead, enter the port number in the “Port” field.

    However, I see that you have the following rpcallowip line:

    rpcallowip=31.22.4.221

    But when I lookup your website it reports an IP ending with 222:

    Name:	diners.ltda
    Address: 31.22.4.222

    Try adding the line rpcallowip=31.22.4.222 to your conf file and restart your wallet.

    The wallet must accept incoming connections from the IP where WordPress is running.

    with regards

Viewing 10 posts - 16 through 25 (of 25 total)

You must be logged in to reply to this topic.