Open extra topbar

Issue when full node monero install + integrate

If you are new here, please see some information on how to ask for support. Thank you!

Issue when full node monero install + integrate

dashed-slug.net Forums Monero Coin Adapter extension support Issue when full node monero install + integrate

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #8631
    angrybird
    Participant

    Hi,

    I’m trying to install a full node of Monero and integrate with Wallet on WordPress. Do you have video or more detail guideline for this installation and configuration?
    I’ve tried enable offline RPC but still can’t connect while it listening on same server.

    #8634
    alexg
    Keymaster

    Hello,

    Unfortunately I do not have a video.

    The instructions are given in the adapter’s homepage, under “installation instructions -> complete instructions”.

    Please describe what you’ve done so far, where you got stuck, and what errors you see.

    with regards

    #8635
    angrybird
    Participant

    Hi Alexg,

    I’ve successfully run monero daemon on server and saw it’s listening on the same port in rpc configure file. But when follow to your guy create wallet, it returned this error message:

    Error: wallet failed to connect to daemon: 127.0.0.1:18081. Daemon either is not started or wrong port was passed. Please make sure daemon is running or change the daemon address using the ‘set_daemon’ command.

    While Monero daemon still running and listen to this port. The next step also not complete with monero-wallet-rpc command at step (6) in this instruction: https://www.dashed-slug.net/bitcoin-altcoin-wallets-wordpress-plugin/monero-coin-adapter-extension/
    The error message:

    This is the RPC monero wallet. It needs to connect to a monero
    daemon to work correctly.

    Monero ‘Nitrogen Nebula’ (v0.16.0.0-release)
    Logging to ./monero-wallet-rpc.log
    2020-06-22 07:48:06.562 W Loading wallet…
    2020-06-22 07:48:08.927 W Loaded wallet keys file, with public address: 43JEbYhRcPwVsacHt5dDxLLeqh9kNzRFY4eYpiPB1bR6TkdSMZyjA8AYfensaKs2MwLtZnwLN1NN2dxM1JgrvtGj2xxxxx
    2020-06-22 07:48:09.432 E Blocks start before blockchain offset: 0 2092500
    2020-06-22 07:48:09.585 E !m_blockchain.is_in_bounds(current_index). THROW EXCEPTION: error::out_of_hashchain_bounds_error
    2020-06-22 07:48:09.833 E (m_blockchain.size() == stop_height || (m_blockchain.size() == 1 && stop_height == 0) ? false : true). THROW EXCEPTION: error::wallet_internal_error
    2020-06-22 07:48:09.838 E Failed to setup background mining: BUSY
    2020-06-22 07:48:09.839 I Binding on 127.0.0.1 (IPv4):18082
    2020-06-22 07:48:12.179 F Error starting server: Failed to bind IPv4 (set to required)
    2020-06-22 07:48:12.179 E Failed to initialize wallet RPC server

    I’m sure all ports are listening but still have error. Wallet synchronization has been completed.

    #8636
    alexg
    Keymaster

    It looks like you haven’t managed to create a wallet yet (step 3), so there’s no point in attempting any more steps. Focus on completing each step before continuing to the next.

    In this case, you’re running the daemon, but monero-wallet-cli cannot connect to the daemon to create a new wallet. Find out why this is so. Here’s some thoughts:

    Are you sure the daemon is still running? It should be listening on 18081 by default. Ideally you should set up a service to make sure it’s always running. You can check if the daemon port is open with nc -zv 127.0.0.1 18081

    Is the daemon running on the same server as the machine where you’re running monero-wallet-cli? If not, use monero-wallet-cli with --daemon-address to specify a different IP/port pair, but in that case you’d need to check your firewalls too.

    Some times there are more than one processes running, and only the first one can get a hold of a TCP listen port. If necessary, reboot your server to make sure that you don’t run any duplicate processes.

    In summary, it’s clear that monero-wallet-cli is looking for the daemon at 127.0.0.1 and port 18081 and it’s not finding it. Check with netcat (nc) as shown above, to make sure the local port is open.

    Hope this helps. Let me know what you found.

    with regards

    #8640
    angrybird
    Participant

    Hi Alexg,

    Please see:

    nc -zv 127.0.0.1 18081
    Ncat: Version 7.70 ( https://nmap.org/ncat )
    Ncat: Connected to 127.0.0.1:18081.
    Ncat: 0 bytes sent, 0 bytes received in 0.01 seconds.
    –>> connected status.

    netstat -tlupn |grep monero
    tcp 0 0 0.0.0.0:18080 0.0.0.0:* LISTEN 4229/./monerod
    tcp 0 0 127.0.0.1:18081 0.0.0.0:* LISTEN 4229/./monerod
    tcp 0 0 127.0.0.1:18082 0.0.0.0:* LISTEN 4229/./monerod

    I’ve tried with –daemon-adress before and saw:

    ./monero-wallet-cli –daemon-address 127.0.0.1:18081
    This is the command line monero wallet. It needs to connect to a monero
    daemon to work correctly.
    WARNING: Do not reuse your Monero keys on another fork, UNLESS this fork has key reuse mitigations built in. Doing so will harm your privacy.

    Monero ‘Nitrogen Nebula’ (v0.16.0.0-release)
    Logging to ./monero-wallet-cli.log
    Specify wallet file name (e.g., MyWallet). If the wallet doesn’t exist, it will be created.
    Wallet file name (or Ctrl-C to quit): gy
    Wallet and key files found, loading…
    Wallet password:
    Opened wallet: 43JEbYhRcPwVsacHt5dDxLLeqh9kNzRFY4eYpiPB1bR6TkdSMZyjA8AYfensaKs2MwLtZnwLN1NN2dxM1JgrvtGj28Jxx6d
    **********************************************************************
    Use the “help” command to see the list of available commands.
    Use “help <command>” to see a command’s documentation.
    **********************************************************************
    Error: wallet failed to connect to daemon: 127.0.0.1:18081. Daemon either is not started or wrong port was passed. Please make sure daemon is running or change the daemon address using the ‘set_daemon’ command.
    Background refresh thread started

    and In monero-wallet-cli.log has this issue:

    2020-06-22 10:25:11.891 7f83a82f27c0 INFO logging contrib/epee/src/mlog.cpp:273 New log categories: *:WARNING,net:FATAL,net.http:FATAL,net.ssl:FATAL,net.p2p:FATAL,net.cn:FATAL,global:INFO,verify:FATAL,serialization:FATAL,daemon.rpc.payment:ERROR,stacktrace:INFO,logging:INFO,msgwriter:INFO

    Server has been reboot many times but still facing with this issue. Could you please advise.

    #8646
    alexg
    Keymaster

    OK, thank you for the additional info.

    I tested again with Monero 0.16.0.0 and I got the same result.

    It appears my installation instructions are outdated, so please accept my apologies; hope you didn’t waste too much time on this. I have now updated the instructions on the adapter’s homepage.

    Step 3: I have added the --no-zmq parameter to the monerod command, because now the daemon binds ZMQ to port 18082 by default, but we don’t need it. If you actually need to use ZMQ for a different application connecting to the same wallet, then you should use a different RPC port.

    So, the full command would be:

    monerod --rpc-bind-port 18081 --rpc-login monero_daemon_user:monero_daemon_pass --no-zmq

    Step 4: You should start the wallet CLI with the daemon-login parameter, which should match the username/password that you set on the daemon.

    So, the full command would be:

    monero-wallet-cli --daemon-login monero_daemon_user:monero_daemon_pass --wallet-file /path/to/monero/wallet

    Let the CLI sync the wallet (wallet sync is a separate process to the daemon sync). Then, proceed to start the monero-wallet-rpc service. This is the service that provides the API that the WordPress plugin uses.

    Please let me know if you face any more issues.

    with regards

    #8651
    angrybird
    Participant

    Alexg,

    I’ve done to resolve this issue by change port of from 18082 to another due to monerod has been owned this port and all thing working well. I have another question relating to wallet.

    My customer hired my team to build a website and payment through XMR. For running, I created a wallet address at /coin/abc (abc is wallet name) but it’s not wallet address of website owner.
    Could you please how him can change the address without touch to server or disclosure his wallet password? He only want to access to admin and change to his wallet address.

    #8655
    alexg
    Keymaster

    Hello,

    Glad it’s working now. You may still want to disable the message queue subsystem, if it’s something you’re not using.

    Regarding your other question, I can’t give you a simple answer without more information. Very often clients think they know what they want without an understanding of the difference between business requirements and implementation details. Please open a new thread and describe your client’s motivation for doing this. We can then explore possible solutions.

    with regards

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.