Open extra topbar

Form does not appear on custom posts

If you are new here, please see some information on how to ask for support. Thank you!

Form does not appear on custom posts

dashed-slug.net Forums Tip the Author extension support Form does not appear on custom posts

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #9094
    bigblue
    Participant

    Alex,

    I do not know why, but it seems now it is not working on custom posts. It was working and now not, the form or the button does not appear.

    In settings everything is setted correctly, those custom posts in post type filter are selected.

    How can I jnow why it is not working? (no errors in console)

    Thanks

    Regards

    #9097
    alexg
    Keymaster

    Hello,

    The only thing that’s changed with respect to when the UI is shown, is the new capability. The plugin checks to see that the current user has the tip_the_author capability and that the author has the receive_tip capability. So first ensure that the capabilities are assigned to the users. If you assign the capabilities to the user roles, check to see if the capability is assigned to all the user roles for your users, as a user can belong to multiple roles.

    Check the above and let me know if you are still encountering this issue.

    with regards

    #9124
    bigblue
    Participant

    Hello Alex,

    I checked the capabilities and they are correctly configured. I tested with a normal auhtor post and it works.

    The thing is that in the extension settings, all custom posts appear and I select those I want to appear for the extension, but it does not working for all.

    Making some searches I noticed that it works by times and others not. It is for cpt posts submited from frontend, where there is a WYSIWYG editor. Information submited from the editor should appear with “tip the Author”.

    There is no errors in console, all settings are correct, an in the error log there is nothing related. What can be the problem here?

    Thanks in advance

    #9128
    alexg
    Keymaster

    Hello,

    I do not know why it doesn’t work.

    1. Again, since I have changed nothing else besides the new capability, this has to do with the capability. Go to your author and assign the receive_tip capability directly, (i.e. directly to the user, not to the user role). Also, go to the user you use to visit the post, and assign the tip_the_author capability directly to the user (not the user role). Does this make a difference?

    2. What do you mean by “it works by times and others not”? What changes between tries? Please provide as much information as possible so I can reproduce the issue.

    with regards

    #9132
    bigblue
    Participant

    Hello Alex,

    Before posting anything I make sure to double check the issues.

    1. This is set correctly. I made a test with standard posts and it appears, but not for cpt. I checked the capabilities in detail.

    2. I give you all the information I have, that’s why I check the debug file, console… but nothing. I went to previous version and it seems not related to the new version, I am not able to find why. The thing is that from frontend users submits a post, where there is a WYSIWYG editor.

    Providing the form using a shortcode would be possible?
    An option to check from backend on each post page that the extension is activated and showing the tips that heve been made?

    Thanks in advance

    Best regards

    #9150
    bigblue
    Participant

    Alex,

    On the frontend form, here are some info from the console

    class=”cmb-row cmb-type-wysiwyg cmb2-id-b-desc” data-fieldtype=”wysiwyg”
    class=”cmb-td”
    id=”wp-b_desc-wrap” class=”wp-core-ui wp-editor-wrap tmce-active”
    id=”wp-b_desc-editor-tools” class=”wp-editor-tools hide-if-no-js”
    id=”wp-b_desc-editor-container” class=”wp-editor-container”

    Much appreciated your help

    Best regards

    #9154
    alexg
    Keymaster

    Hmm, that’s a weird one.

    The fact that even after reverting to the previous version the problem remains, means that this is probably something else.

    What I can do, is add a few debug prints in the logic that controls when the UI is shown. Then you can enable WordPress logging and see what’s going on.

    I will do this soon and let you know.

    In the meantime, please try with some plugins disabled, particularly CMB2 if you have it installed, and tell me please if you see any difference.

    Finally, the ids and classes that you found in your console should have some context. Is this part of an error you see? How come this information is in your console? If possible can you show me a screenshot of where you found this information?

    with regards

    #9166
    alexg
    Keymaster

    Hello again,

    I have added debug prints into the latest version 2.1.1 of the extension.

    1. First enable debugging. Then, view a custom post. Either the UI will be shown, or you will get an error message in the debug.log file, explaining why the UI was not shown.

    2. Let me know if you got a chance to test again with CMB2 disabled.

    3. This could also be an issue related to the theme. Let me know if you tested with a different theme.

    with regards

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.