Open extra topbar

exchange rate problem

I reply to all queries on the forums and via email, once per day, Monday to Friday (not weekends).

If you are new here, please see some information on how to ask for support. Thank you!

exchange rate problem

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2606
    clickforafrica
    Participant

    Hi, I have an instance using WooCommerce along with a subscription plug-in at http://satoshihost.com/ – I am using a similar system at lottofaucet.com and it is all working ok (minus the subscription part)
    When I go to checkout on the satoshihost site I get an error message:

    Payment error: The exchange rate for the selected cryptocurrency is not currently available. Please try again later or choose to pay with another currency or payment method.

    I tried all I can think of that’s related to exchange rates… I don’t even need any exchange rates, at the moment it’s all in LTCT and PayPal is disabled.
    any pointers as to where the source of the exchange rates thing is located would be a help. I just need to disable it all as I don’t need any exchange rates.
    Thanks
    andy

    #2618
    alexg
    Keymaster

    Hi Andy,

    You cannot simply disable that, since the WooCommerece plugin needs the exchange rates API.

    The issue here is that you are correctly using LTCT to test the site, but there is not an actual coin with that symbol.

    I will change the code to make sure that LTCT has an exchange rate, possibly the same as LTC, so that you can proceed with your tests.

    Thank you very much for reporting.

    #2625
    alexg
    Keymaster

    Hi again,

    Please do the following to resolve this issue:

    1. Upgrade your CoinPayments adapter to the latest version, 1.0.1

    2. Go to Wallets -> Rates and enable one of the exchange rate providers. This is necessary for the WooCommerce payment gateway extension.

    3. Wait for 5 minutes, or whatever the “Rates cache expiry (minutes)” option is set to.

    After that, the LTCT symbol should be assigned with an exchange rate.

    kind regards

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.