Open extra topbar

Error after activating plugin (500)

If you are new here, please see some information on how to ask for support. Thank you!

Error after activating plugin (500)

Tagged: , ,

This topic contains 6 replies, has 2 voices, and was last updated by  Nayiem 5 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #5282

    Nayiem
    Participant

    After activating the plugin, the website becomes very slow.
    Sometimes with a 500 error.
    The website also does not properly format the layout.

    After deactivating the plugin, the website responds normally.

    #5283

    alexg
    Keymaster

    Hello,

    Most likely this is due to a firewall causing timeouts. Which coin adapter are you using?

    To be clear, does the site become slow when you activate the woocommerce extension? Or the parent plugin?

    Most likely this is caused by the parent plugin. If you like, you can also check the Troubleshooting section of the documentation under “When I activate the plugin, my WordPress becomes extremely slow and is unusable.” or “When I activate the plugin, my WordPress becomes somewhat slow but is still usable.” for some thoughts. The documentation is available in the bundle download of the plugin at https://www.dashed-slug.net/bitcoin-altcoin-wallets-wordpress-plugin/

    Also this would happen if your server has extremely small memory allocated to WordPress.

    Please have a look and let me know if these instructions do not help you.

    with regards

    #5284

    Nayiem
    Participant

    The website becomes unusable after activating the Woocommerce Payment Gateway extension.
    Once everything is activated the memory consumption is about 60% at peak. But usually 40%.

    The parent plugin is working fine.
    I will have a look at the timeout and firewall settings.

    #5285

    Nayiem
    Participant

    Migrated to another server.

    Old settings: 1x CPU Dual Xeon 2.6 ghz & 4 GB RAM
    New settings: 2x CPU Quad Xeon 2.9 ghz & 48 GB RAM

    Old settings was consuming 100% CPU power.
    New settings only a fraction.

    Thanks 🙂

    #5291

    alexg
    Keymaster

    Hello,

    That’s strange. Even the old configuration should be more than enough for the plugin. However, the total server memory is not what’s important. What is important is the memory allocated to PHP, and out of that, what portion is actually allocated to WordPress, via the constant WP_MEMORY_LIMIT.

    I suspect that the plugin works in your new configuration due to some PHP or WordPress setting, and not due to the machine being more powerful.

    with regards

    #5292

    alexg
    Keymaster

    In my WordPress I observe how much of the available memory is actually used, with this plugin: https://wordpress.org/plugins/server-ip-memory-usage/

    #5299

    Nayiem
    Participant

    I think the allocated memory was misconfigurated.
    The plugin is working fine now.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.