Open extra topbar

deposit not showing until i do a manual api call

If you are new here, please see some information on how to ask for support. Thank you!

deposit not showing until i do a manual api call

dashed-slug.net Forums Full Node Multi Coin Adapter extension support deposit not showing until i do a manual api call

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #7426
    krewshul
    Participant

    so it is probably my fault and i clicked a box wrong or something but i can send coin to the deposit address and it wont show in user available balance or in the transactions list at all. it does however show in the cold wallet balance. i have my cron set up at easycron, as suggested and it is running fine. i have disabled the transients as suggested in a previous support thread. i have tried putting # of confirms down to 0.. i havey conf file set up with the alerts

    walletnotify=curl -sk https://urcryptodepot.com/wallets/api3/notify/FCK/wallet/%s >/dev/null
    blocknotify=curl -sk https://urcryptodepot.com/wallets/api3/notify/FCK/block/%s >/dev/null
    alertnotify=curl -sk https://urcryptodepot.com/wallets/api3/notify/FCK/alert/%s >/dev/null

    but still nothing shows untill i run
    https://www.urcryptodepot.com/wallets/api3/notify/FCK/wallet/"MYTXID#"

    any thoughts on what i am doing wrong?

    #7431
    alexg
    Keymaster

    Hello,

    Yes, you should set the walletnotify argument in your full node wallet to call this notification URL. This way, every time the wallet sees a new transaction, or a new confirmation for an existing transaction, it will tell the plugin to check that transaction. This is in the instructions you see at first when you still haven’t set up the coin adapter correctly.

    To use curl in your notification mechanism, you’d add something like the following in your wallet’s .conf file:

    walletnotify=curl -sk https://www.urcryptodepot.com/wallets/api3/notify/FCK/wallet/%s >/dev/null
    blocknotify=curl -sk https://www.urcryptodepot.com/wallets/api3/notify/FCK/block/%s >/dev/null
    alertnotify= curl -sk https://www.urcryptodepot.com/wallets/api3/notify/FCK/alert/%s >/dev/null

    Restart your wallet after adding the above settings.

    Also, don’t forget to increase the number of confirmations again.

    Finally, don’t forget to re-enable transients. Disabling that debug setting will impact performance by a lot.

    with regards

    #7445
    krewshul
    Participant

    sorry im confused because the conf file walletnotify you posted is exactly the same as the one i posted. am i missing something?

    #7447
    alexg
    Keymaster

    The question is whether your wallet is able to trigger that url.

    – Did you restart the wallet?
    – Is there a firewall in the middle blocking the call?

    Perhaps you can try the curl command from the machine that runs the wallet and see if it works. Remove the silent (-s) argument to be able to see errors. So, you might try, from your wallet machine:

    curl --verbose -k https://www.urcryptodepot.com/wallets/api3/notify/FCK/wallet/SOMETXID

    and see if the command fails.

    #7449
    krewshul
    Participant

    yes there have been a couple restarts since the conf set up originally. ill try without the -s wallet has been white listed and allowed through firewall. even tried by turning firewall off completely. couple thoughts i had that could be messing it up. but not sure. 1. Cloudflare… i do have cloudflare set up on my site. and 2. this is an older base code. i believe it is based on bitcoin v0.8.12 or something close to that. so i do have the api2 option checked. if it is running off api2 would i need to change it to api2 in the command or will the api3 still make the call for me.

    and for clarification, you posted curl --verbose -k https://www.urcryptodepot.com/wallets/api3/notify/FCK/wallet/SOMETXID when you write “SOMETXID” does it matter which one i use? or will i have to manually set it for each transaction that comes in? i like to be lazy and really dont want to have to for each tx.

    and sorry for so many questions. i swear i do trouble shoot and try to research before i bug ya. i know how tedious moderating and handling support can be especially when your the programmer.

    #7450
    alexg
    Keymaster

    Hello,

    It’s at least remotely possible that cloudflare is causing this. Or your server-side cache is preventing the API call, although I find this unlikely: Even if a single such URL is cached, that can’t affect any other transactions, since the TXID is part of the request URL and it’s different every time.

    The plugin’s JSON API2 and API3 should be equivalent as far as the notify mechanism is concerned so it makes no difference. To use API2 with the latest version of the plugin, you’d first need to enable “Legacy JSON APIs” from the frontend settings. I wouldn’t do this if I were you. Since you already know that you can trigger the notify mechanism from your browser, the issue is not with the plugin.

    You can try any transaction ID to see if you get a response. The call simply tells the plugin to go query that transaction, if it is a fake or non-existend transaction then nothing happens. But in any case you should see a JSON response with result: success, meaning that your request was submitted successfully, not that the transaction was found necessarily.

    Since you know that the plugin works when you trigger the URL manually, this is something that has more to do with the wallet than with the WordPress plugin. You should focus on why the actual wallet does not do the same call. Perhaps you can redirect the output of the curl call to some log file, for example:

    walletnotify=curl -k --verbose https://www.urcryptodepot.com/wallets/api3/notify/FCK/wallet/%s >>~/walletnotify.log

    Then your ~/walletnotify.log file should contain some output.

    Or check your webserver’s access log and see if the wallet is making the calls you expect to see.

    Hope this helps.

    with regards

    P.S. I am happy to answer any specific questions, such as yours. It’s my choice to work alone so it’s cool. I can usually handle the context switching, and when I can’t, I just answer everything on the next morning 🙂

    #7452
    krewshul
    Participant

    sweet. thanx. ill test when i get the site back up. i really appreciate the help. in the back of my mind i kinda thought it was the wallet itself. but didnt want to admit since i was the one that fixed the wallet here recently. thats just means i probably missed something. eh.. oh well. thanx again. have a good one!

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.