Open extra topbar

Default Coin in Frontend

If you are new here, please see some information on how to ask for support. Thank you!

Default Coin in Frontend

dashed-slug.net Forums General discussion Default Coin in Frontend

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6649
    tanger
    Participant

    I’ve tried setting this at Wallet > Frontend Settings > Default Coin

    and on the individual page with no results.

    It appears that if you are logged out, the default coin is in alphabetical order no matter the setting on the frontend or page level.

    If you are logged in, the frontend settings are correct.

    #6654
    alexg
    Keymaster

    Hello,

    I am not sure I understand. The default coin selection should not change the ordering of the coins. Additionally, this setting does not make sense if you are not logged in, since you should not be seeing the frontend shortcodes anyway. The default coin selection simply chooses the default coin if you are logged in.

    What did you expect to see instead?

    #6657
    tanger
    Participant

    For example. I want to offer Monero and Litecoin BTC_XMR and BTC_LTC exchange. If I put the order book on the landing page so people can see what is available without logging in [wallets_exchange_market template=”simple-dropdown”] [wallets_exchange_bids] and [wallets_exchange_asks] – XMR Monero is the most popular asset with the most liquidity and I would like to be able to show the most active order book on the landing page. Right now, the landing page displays BTC_LTC before BTC_XMR without logging in… and my litecoin order book is nearly empty.

    I hope that makes sense.

    #6658
    alexg
    Keymaster

    Ah, OK. Now I understand.

    The setting you are tweaking is for coins – and it affects UIs for the parent plugin, Bitcoin and Altcoin Wallets.

    What you actually want to do is affect the default market, within the context of the exchange extension.

    Right now it’s not possible to affect the ordering of markets, but it is possible to select one market that is pre-selected when the page loads:

    Go to “Wallets” -> “Exchange” -> “Markets” and use the radio button under the “Site-wide default” column, to select the default market.

    Hope this helps.

    with regards

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.