Open extra topbar

Cron

If you are new here, please see some information on how to ask for support. Thank you!

Cron

Tagged: , ,

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #5051
    bigblue
    Participant

    Alex,

    Thank you for this last release, I feel like performance improved compared with the previous version, excellent.

    Just a request if it is possible its implementation. I have read that for an external cron, we should disable all wp cron in config, but what about the rest of internal cron tasks performed with wp-cron?

    Can you if possible implement an option in order to create a cron for wallets without disabling wp-cron?

    Thank you

    Best regards

    #5059
    alexg
    Keymaster

    Yes, this is possible.

    However in the meantime, I would recommend that you do the following:

    Do not disable wp-cron, but do install the system cron. Most of the load will be removed from user requests.

    with regards

    #5082
    bigblue
    Participant

    Hi Alex,

    I installed the cron system (with wp-cron enabled) but I dont see major changes in terms of performance on front end. The email notification I get about the cron task is {“result”:”success”}.

    It is the expected behaviour in this case?

    Thank you

    Best regards

    #5089
    alexg
    Keymaster

    Hello,

    The performance improvement will be more apparent if you have many users performing transactions. If there are no transactions to execute then it will not make any difference.

    The expected result is the one you report. It is also shown in the documentation in the JSON API reference.

    with regards

    #5094
    bigblue
    Participant

    Thank you Alex for the information.

    On WP Cron events dashboard I am getting the next message:

    “There was a problem spawning a call to the WP-Cron system on your site. This means WP-Cron events on your site may not work. The problem was:
    cURL error 28: Operation timed out after 3003 milliseconds with 0 bytes received”

    It is because 2 crons are executing at the same time? one from wp-cron and another from server side?

    Thank you

    Best regards

    #5096
    alexg
    Keymaster

    Hello,

    No, actually there should not be any problem with running multiple cron jobs, both initiated from the WordPress wp_cron and from the system (server) crontab.

    If incoming deposits and internal transactions are processed, then this means that your system is set up correctly.

    Can I ask, what is the “WP Cron events dashboard”? Is this from some cron-related plugin? Let me know which one and I will have a look.

    thanks

    with regards

    #5097
    bigblue
    Participant

    I see, I tested a transfer transaction and it works with both cron jobs.

    Yes, about cron-related plugin, It is useful for cron task control. Please have a look: WP Crontrol

    A question, on admin backend, in wallet>cron job, the settings should be the same as the settings in server cron system? for example if I set it to run every minute, on server cron system I have to set it to run every minute?

    Thank you Alex

    Best regards

    #5098
    alexg
    Keymaster

    Thanks I will look at that plugin.

    The settings do not have to be the same. Each type of cron trigger can have its own interval.

    with regards

    #5131
    alexg
    Keymaster

    Hello,

    In version 3.9.0 it is now possible to disable internal triggering of cron jobs. Simply set the “Run every” option to the value “(never)”. As discussed before, you should only do this if you have correctly setup a system cron that triggers the plugin’s cron jobs via curl.

    with regards

    #5134
    bigblue
    Participant

    Hi Alex,

    Thank you for the information and this promising update. I am going to update and will let you know if any issue or how good it works in my case.

    Thanks again,

    Best regards

    #5136
    bigblue
    Participant

    Alex, for now It works perfect!

    Just some questions:

    It is normal not seing a major difference in front end performance?

    In terms of scalability, do you have some numbers about max possible users and needed server capacity?

    Thank you

    Best regards

    #5140
    bigblue
    Participant

    Hi Alex,

    Since this morning, I am getting this message from my server:

    {“result”:”error”,”code”:0,”message”:”Error while trigerring cron tasks: You must supply the cron nonce.”}

    What could be the problem?

    Cron from wp-cron is deactivated, and server system cron is setted to work every minute.

    Thank you in advance

    Best regards

    #5141
    alexg
    Keymaster

    Hello,

    If you offload cron job tasks away from user requests, this will make a difference in frontend performance, but only if your site has enough traffic.

    Unfortunately I do not have numbers for you in terms of matching number of users or requests to server capacity.

    About your other question, it seems that the cron nonce has changed. This would happen if you uninstalled and re-installed the plugin. Simply use the new cron nonce in your curl command.

    with regards

    #5144
    bigblue
    Participant

    Thank you Alex for your quick reply.

    Yes, you are correct, I checked, and I found the cron nonce changed. It is strange because I updated much earlier an did not get any non success cron notification, and I found in the admin backend the wp-cron turned ON to three minutes (I had turned it to “never”).

    I have a cron job for backups at night from my server. I dont think this is the reason, but I will check for tonight if it happens again this mistery.

    Now, I changed the cron nonce and everything in order.

    Thanks Alex

    Best regards

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.