Open extra topbar

Could not add trade pair.

If you are new here, please see some information on how to ask for support. Thank you!

Could not add trade pair.

dashed-slug.net Forums Exchange extension support Could not add trade pair.

This topic contains 12 replies, has 2 voices, and was last updated by  alexg 2 months, 2 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #5232

    vorticism
    Participant

    In my case, adding a new trade pair does not show the added market at the front end.
    Can you give me tips on how to fix this?

    #5234

    alexg
    Keymaster

    Hello,

    Thanks for reporting. I am not able to reproduce the problem on my end. Could you please check the following?

    1. Are you able to add a row to the markets table, by clicking on “Add row”?

    2. Have you set your market to “Enabled”?

    3. When you click on “Save Changes”, do you see any error?

    4. Are the wallets for both coins of the pair online and responding?

    5. Are you on a multisite install?

    6. Roughly how many markets have you already added successfully?

    Let me know please.

    #5236

    vorticism
    Participant

    1. YES
    2. YES
    3. There is no error mark.
    4. YES

    * 5. I am using multi-site. Exchange plugin are active at the network level.

    6. Only one pair is in use from the beginning to the present. However, I have added a pair to the test. At that time, I was successful.
    I can not add it now. No other problems are displayed in the backend.

    #5243

    alexg
    Keymaster

    Thank you for the very detailed answer.

    I am trying to reproduce the problem but I am yet unable to do so. In my tests, I can add a market successfully, when the plugin is network activated.

    If it’s not too much to ask, could you please also tell me the following?

    1. Does the new market appear in the *admin screen* after you click on “save changes”? i.e. is it listed under Wallets -> Exchange -> Markets?

    2. What is the output when you navigate to https://example.com/?__wallets_exchange_action=get_market_summaries (replace example.com with your site’s domain).

    3. In your browser’s JavaScript console, what is the output of the following?

    JSON.stringify( wp.wallets.viewModels.walletsExchange.marketSummaries() );

    Thank you for your help.

    #5246

    vorticism
    Participant

    1. Yes, the list is successfully added to the backend.

    2.
    {“market_summaries”:{“BTC_DOGE”:{“market”:”BTC_DOGE”,”min_ask”:”0.00000093″,”ask_volume”:”6001.58717224″,”ask_volume_base”:”9.00583347″,”max_bid”:”0.00000092″,”bid_volume”:”39523.26159308″,”bid_volume_base”:”0.03180521″,”trade_volume_base_24″:”0.00018360″,”trade_volume_quote_24″:”197.80692640″,”last_price”:”0.00000092″,”percent_change_24″:”-2.13″}},”result”:”success”}

    3.
    {“BTC_DOGE”:{“market”:”BTC_DOGE”,”min_ask”:”0.00000093″,”ask_volume”:”6001.58717224″,”ask_volume_base”:”9.00583347″,”max_bid”:”0.00000092″,”bid_volume”:”39523.26159308″,”bid_volume_base”:”0.03180521″,”trade_volume_base_24″:”0.00018360″,”trade_volume_quote_24″:”197.80692640″,”last_price”:”0.00000092″,”percent_change_24″:”-2.13″}}

    My backend now has the BTC_DOGE & BTC_XRP market active.

    Thank you for your help.

    #5249

    alexg
    Keymaster

    Thank you.

    This is very strange. I suspect your server cache, as the JSON-API responses are normally cached for a few seconds using transients. If you can, please try the following:

    1. In Wallets -> Exchange -> JSON API -> “Seconds to memoize market API calls”, try setting this to 0. It will disable caching of the JSON API response. Does the market appear in the frontend after this change?

    2. Clear your server-side object cache (w3 total cache, memcached, etc) It’s a long shot but worth a try.

    #5271

    vorticism
    Participant

    There is currently no cache issue, but the issue still exists. (Both server side and wp side cache off)

    There are additional issues.
    A size order of 0 is not filled.
    I tried several methods but could not remove this order. (Attachment) Is there a way to force removal?

    Attachments:
    You must be logged in to view attached files.
    #5295

    alexg
    Keymaster

    About the 0 order, you can always solve it via SQL with a UPDATE wp_wallets_orders SET status='filled' WHERE amount=0; and this should resolve your immediate issue. I will see what I can do so that this does not happen.

    I am still not sure why the market is not added in your frontend. Still investigating.

    with regards

    #5303

    vorticism
    Participant

    Thank you
    There was an open order with amount of 4.2 and a filled of 4.2.
    I changed the status to filled (in phpmyadmin) and the problem is resolved.

    #5309

    alexg
    Keymaster

    As promised I will soon patch the exchange so that this issue with 0 amount orders does not occur.

    About the issue regarding adding markets, could you try the following?

    1. Update the parent plugin to the latest version 3.9.2

    2. Go to Wallets -> Frontend settings -> JSON API Settings and check Disable transients (debug).

    3. Visit the frontend again and see if your new market appears now.

    4. If there is no change, deactivate the option again, as it will make the plugin somewhat slower when checked.

    #5344

    vorticism
    Participant

    If I check ‘Disable transients (debug)’ and save the settings, the option is unchecked.
    Can not save as checked.
    There are no other cache issues that I can understand.

    #5346

    alexg
    Keymaster

    Oops the option does not get written on multisite. I will fix that in the next patch of the parent plugin.

    I am still unable to determine why you would be unable to view the market. From all the clues you’ve given me it seems that you are able to add it correctly to your database, but the JSON API does not report it to the frontend.

    Very strange indeed.

    #5476

    alexg
    Keymaster

    Hello,

    Are you still experiencing the issue of not being able to add a market to the Exchange?

    If you are interested, there are two things you can check:

    1. Install the latest version of the parent plugin, 3.9.3, released just now. You will now be able to check the setting “Disable transients (debug)” in a multisite install. Does this make a difference? Do you see the markets in the frontend when this is checked? If not, then uncheck the option again as it will make your plugin somewhat slower when checked.

    2. Could you please check to make sure that both the parent plugin and the exchange extension are network-activated? If one of the plugins is activated on a single site then it might not work. I would therefore recommend that you go to network admin settings and deactivate both plugins, then check that they are deactivated in your site where you do your tests, then finally network activate both plugins again.

    with regards

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.