Open extra topbar

Chart not displaying

If you are new here, please see some information on how to ask for support. Thank you!

Chart not displaying

dashed-slug.net Forums Exchange extension support Chart not displaying

Tagged: , , ,

This topic contains 14 replies, has 4 voices, and was last updated by  bigblue 1 year, 4 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #3398

    San
    Participant

    Hello Alex,

    Great job! congratulations for Exchange release and thanks for great work.

    Chart is not displaying, any idea how do i fix it?

    Thanks

    #3401

    bigblue
    Participant

    The same issue for me. It remembers me an issue I have related with Tip extension, not displaying the form which in this case contains the chart.

    I’m testing it and it looks good. I try to create a new market with LTC Test to LTC Test but it does not save it. I want to do this for testing purposes.

    Thank you Alex for this great work and your support,

    Best regards

    #3402

    RichardObradovic
    Participant

    The same issue for me.

    Best regards

    #3404

    alexg
    Keymaster

    Hello everyone,

    Thanks for your initial feedback.

    The chart ([wallets_exchange_chart] shortcode) is expected to be empty when you first install the plugin. This is how it should look like:

    empty chart in exchange extension

    When the UIs are first loaded they are grayed out (opacity set to 50%). Then, as all the data is loaded from the JSON API, the UIs will turn to opacity 100%. If you are seeing the above chart at opacity 100% then all is fine, your orderbook is simply empty. As you know, candlesticks only represent executed orders.

    @bigblue: You cannot set a market to have the same symbol for base and quote currency. If you are testing in a local environment you can set up a bitcoin testnet and litecoin testnet node using the full node multiadapter extension. If you are on a hosted server that you use only for testing( i.e. is closed to the public), you can simply create any markets to test. Even if you use real currencies, no blockchain transactions will be executed unless you choose to withdraw your funds. Therefore you can do your tests and then wipe the DB tables (wp_wallets_txs, wp_wallets_adds, wp_wallets_orders) once your tests are done.

    #3410

    bigblue
    Participant

    Thank you Alex for your answer.

    Yes, you are absolutely right, candlesticks are expected when orders are executed, but the thing is that the axis does not show up, and it’s why I think there is some issue. The timeframe dropdown menu works, but axis and scale does not show up. For this first install I used the page creator from the plugin.

    For operations testings I’m using a cloud adapter, I will see if they offer BTC testnet in order to create a testnet market.

    Thank you verry much Alex, I truly appreciate your dedication and support,

    Best regards,

    PS: if it’s not the same issue I commented related to form, for Tips extension I will be back to you sending you an email to see what is wrong for the issue we commented in the appropiate support topic.

     

    #3413

    alexg
    Keymaster

    @bigblue: Is your market in the enabled state? Are there any JavaScript errors in your console?

    About the Tip the Author extension, please use its support forum as it is probably a different issue.

    kind regards

    #3416

    bigblue
    Participant

    Yes Alex, all the markets I’ve created are enabled in backend and showing up correctly in front. I’m trying to add a picture but it seem not possible. The chart container is blank, no axis are displayed.

    In console I have this:

    GET https://techanjs.org/techan.min.js 0 ()    (index):1466

    wallets-exchange-0.1.0-beta.min.js:3 Uncaught ReferenceError: techan is not defined
    at HTMLDivElement.<anonymous> (wallets-exchange-0.1.0-beta.min.js:3)
    at Function.each (jquery.js:2)
    at a.fn.init.each (jquery.js:2)
    at c (wallets-exchange-0.1.0-beta.min.js:3)
    at Object.success (wallets-exchange-0.1.0-beta.min.js:3)
    at i (jquery.js:2)
    at Object.fireWith [as resolveWith] (jquery.js:2)
    at y (jquery.js:4)
    at XMLHttpRequest.c (jquery.js:4)

    Sorry about mentionning the issue related to Tips extension. Just I was thinking that maybe because they share the same method POST in form and not showing up, it could be something related with server. But OK I will use its support chanel.

    About creating a test market, using cloud service there is no BTC testnet, so I cant use it in demo mode. Do you have plans to add some demo mode for the exchange with non real candelsticks and pairs of coins? With some user capabilities in demo and real context, with the option of upgrading. Novel users could see how it works and test it.

    Thank you Alex,

    Best regards

    #3417

    alexg
    Keymaster

    Thanks for the additional info.

    From the error message it is obvious that the techan library was not loaded. It is likely that this is due to XSS protection. I will include a copy of the library in the next patch release of the extension. Thank you very much for reporting this.

    If you wish to see what the candlesticks look like, you can have a look at the techan library: http://techanjs.org/

    Technical indicators are not implemented, but there are candlesticks, volume bars, and arrows at the user’s buy and sell positions.

    regards

    #3418

    bigblue
    Participant

    Thank you Alex for your answer.

    About XSS protection, yes, I confirm you that is enabled.

    I had a look at thechan library and it looks correct. It would be better if technical indicators are implemented, specially for advanced users, but it is ok.

    Thank you Alex, and looking forward for the next patch release, hoping chart axis will display.

    Best regards

    #3427

    alexg
    Keymaster

    This could be related to a bug that I have now fixed. Can you please try again with version 0.1.1-beta? It will be released shortly.

    I would also like to add technical indicators but it is a lot of work and will happen much later.

    thanks

    #3428

    San
    Participant

    Hi Alex,

    I have enabled testnet and have carried few transactions. Charts seems to be showing.

    Thanks

    #3445

    bigblue
    Participant

    Alex, thank you for this last release. I updated to this last one and the library loads correctly. Now the chart axis are displayed correctly.

    For the moment I cant operate with a testnet in order to create a trade volume and see if trades are executed correctly. The cloud service has only LTCT enabled.

    Thank you Alex for this great work, and you quality support.

    Best regards

    #3446

    bigblue
    Participant

    Alex, something else I just found. The chart is not fully responsive, on mobile screen the chart does not adapt correctly to the screen. On tablet is better.

    Thank you

    Best regards

    PS: about responsiveness, after the last release of the core plugin, the qr code for deposits shows up in full size, if on a PC or tablet, is too big, in mobile it is OK.

    #3460

    alexg
    Keymaster

    @bigblue: Hello,

    Yes I know that the chart is not ideal. Perhaps in the future I can replace it with a custom solution but for the moment there are simply too many other things to do.

    If you need a smaller QR Code, use CSS to restrict the size of the UI.

    If you face other issues, please open a new thread.

    kind regards

    #3476

    bigblue
    Participant

    No Problem Alex, for me it is fine at the moment, there is more important things to test and develop.

    Thank you again for this great work and support

    Best regards

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.