Open extra topbar

"Capabilities" wont Enabled and Stay On..?

If you are new here, please see some information on how to ask for support. Thank you!

"Capabilities" wont Enabled and Stay On..?

dashed-slug.net Forums General discussion "Capabilities" wont Enabled and Stay On..?

This topic contains 4 replies, has 2 voices, and was last updated by  alexg 5 months, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #6486

    piiggybank
    Participant

    Hell,

    I recently noticed all of my users except for the subscriber now have all capabilities off. Regardless of how many times i check the box to enable and press save, it doesn’t save…?

    The fact that this can occur is very concerning. Especially when something like this would cause a lock out to the users on the front end.

    Can someone please advise on this?

    Attachments:
    You must be logged in to view attached files.
    #6490

    alexg
    Keymaster

    Hello,

    Thanks for reporting this issue. I was not able to reproduce it on my end. Could you please tell me the following:

    1. Are you on a multisite install?

    2. If you enable logging, do you see any errors in the WordPress log at the time when you hit save?

    Let me know please. Thank you.

    with regards

    #6494

    piiggybank
    Participant

    Hi,

    I just tried again and the same issue.

    1) only installed on one (1) website.
    2) I do not see any errors.

    Plugin version 4.3.3
    Git SHA cd192cb2
    Web Server Apache
    PHP version 7.0.33
    WordPress version 5.2.1
    MySQL version 10.2.11-MariaDB-log
    DB prefix wpyi_
    Is multisite false
    Is network activated false
    PHP max execution time 30
    Using external cache false
    DB storage engine for ‘wpyi_wallets_txs’ InnoDB
    DB storage engine for ‘wpyi_wallets_adds’ InnoDB
    Constant ‘WP_DEBUG’ false
    Constant ‘WP_DEBUG_LOG’ false
    Constant ‘WP_DEBUG_DISPLAY’ true
    Constant ‘DISABLE_WP_CRON’ n/a
    Constant ‘DSWALLETS_FILE’ /home/creat681/public_html/piiggybank.com/wp-content/plugins/wallets/wallets.php
    Constant ‘WP_MEMORY_LIMIT’ 40M
    PHP.ini ‘memory_limit’ 512M
    Cron jobs last ran on Mon, 17 Jun 19 11:13:22 +0000
    Cron jobs last runtime (sec) 0
    Cron jobs peak memory: 83494424
    Cron jobs memory delta: 2704
    PHP Extension ‘curl’ Loaded
    PHP Extension ‘mbstring’ Loaded
    PHP Extension ‘openssl’ Loaded
    PHP Extension ‘zlib’ Loaded
    Active wallets extensions wallets-cp 1.1.0
    Network-active wallets extensions n/a

    #6495

    piiggybank
    Participant

    Hi,

    Problem solved.

    I used the UM theme. When you add “custom roles”/Custom settings, it overrides the capabilities settings. You must go to your user role settings and manually enable to role permissions at the bottom of the page.

    Attachments:
    You must be logged in to view attached files.
    #6501

    alexg
    Keymaster

    Hello,

    Yes that is correct. In WordPress, individual user capabilities override user role capabilities. The Wallets -> Capabilities page is there for convenience but you can use any plugin that edits capabilities to assign the correct ones.

    Glad you sorted this out. Thanks for sharing this issue with the forum.

    with regards

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.