Open extra topbar

Cannot open wallet until admin provides the passphrase

If you are new here, please see some information on how to ask for support. Thank you!

Cannot open wallet until admin provides the passphrase

dashed-slug.net Forums TurtleCoin Adapter extension support Cannot open wallet until admin provides the passphrase

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #8408
    rbgy8512
    Participant

    Im trying out your new Turtlecoin adapter and have run into an issue. I went through step by step setting this adapter up and I dont know if I am missing something or what, but I am getting this error in the wallets -> adapters -> adapter status “❎ Not responding: Cannot open wallet mysitesdomain.wallet until the admin provides the passphrase”.
    Thought maybe it was something that I had screwed up on my site, so I tried it on a fairly clean wordpress install and i’m getting the same error.
    Thought maybe something was off with the fork I am using, so I compiled the Turtlecoin daemon and wallet-api and ran them and i’m still getting the same error for some reason.

    #8409
    alexg
    Keymaster

    Hello,

    You simply need to enter a secret password in your coin adapter settings, under “Wallet settings” -> “Password”. The plugin will then create a new wallet for your site, and will ask the wallet-api to encrypt the wallet file with this password.

    with regards

    #8410
    rbgy8512
    Participant

    I have entered a password, for some reason its like its not registering that I am providing a password. Attaching some screenshots of the setup.

    Attachments:
    You must be logged in to view attached files.
    #8414
    alexg
    Keymaster

    Thank you for testing! Well, the adapter works on my machine 🙂

    So:

    1. Check your value of the setting: “Cron job” -> “Withdrawal locks” -> “Time to retain withdrawal secrets”. By default this is 0 which means retain passwords indefinitely in the DB.

    2. The passwords are stored as transients. Check your WordPress installation and any caching/optimization plugins to see if they are deleting your non-expired transients. If necessary you can disable such plugins and try again.

    Please let me know if this made a difference.

    #8416
    rbgy8512
    Participant

    So my “Time to retain withdrawal secrets” is set to 0.
    Disabled every plugin except the dashed-slug plugins with the same result unfortunately.

    I thought maybe something was being thrown off because I was using a pre-packaged wordpress multi-site installation that came with a bunch of bs already installed and loaded so I started with a clean install of ubuntu, went through and installed wordpress and its dependencies from scratch to have as clean of an install as possible. Loaded only the Bitcoin and Altcoin Wallets plugin and the Turtlecoin plugin. Started my daemon and wallet-api. Configured the plugin settings, Im getting the same error message saying cannot open wallet until admin provides the passphrase.

    I really appreciate your help. Im not sure where im going wrong on this

    #8417
    alexg
    Keymaster

    Hello,

    OK, I have now tested on multisite and I see that the secrets are not saved when the plugin is network-activated.

    I will release a fix for this and a few other minor issues over the coming days.

    Thank you very much for reporting this issue. I will notify you again here.

    with regards

    #8420
    rbgy8512
    Participant

    No problem at all!

    Thank you very much for all of your hard work!!

    #8426
    alexg
    Keymaster

    Hello,

    I have uploaded a new patch release, 0.1.1-beta of the adapter, where the issue with network-active installations that you discovered is addressed.

    Additionally, the adapter is now shown with a withdrawals lock (padlock) while the node is not yet synced. This will prevent any withdrawal failures while the node is syncing.

    Thank you for reporting this issue.

    with regards

    #8428
    rbgy8512
    Participant

    Awesome thank you! Wallet is now responding. Found another slight issue. Not to do with the passphrase but on lines 281 and 282 of the coin-adapter-turtlecoin.php the filter_input for the daemon-ip and daemon-port are set to rpc-ip and rpc-port so whatever value I set in the UI for the Wallet RPC ip and port was also applied to the daemon ip and port. I changed the filter_input on lines 281 and 282 from rpc-ip and rpc-port to daemon-ip and daemon-port, and the adapter started working. screenshots attached

    Attachments:
    You must be logged in to view attached files.
    #8442
    alexg
    Keymaster

    Oops, yes I see it now. Thank you! I hurried to release the fix on Friday evening without noticing this bug. I will release a fix today. with regards

    #8446
    alexg
    Keymaster

    Version 0.1.2-beta uploaded with the fix. Thank you for testing the component!

    with regards

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.