Open extra topbar

Bytecoin (BCN) deposit issue

If you are new here, please see some information on how to ask for support. Thank you!

Bytecoin (BCN) deposit issue

This topic contains 8 replies, has 3 voices, and was last updated by  alexg 1 year, 6 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2627

    vorticism
    Participant

    In the case of bytecoin(BCN),
    the coin is sent to the user’s BCN_address but is not reflected in the user balance
    I tried six times with different user accounts, but none of them succeeded.
    (Both address and payment ID were checked.)
    The deposit on the master account on coinpayment(online balance in wp-admin) succeeds,
    but not in user frontend and user balance in wp-admin.
    Other coins that I have checked are normally reflected in online balance and user balance.

    #2631

    alexg
    Keymaster

    Thank you for reporting.

    Please disable bytecoin until I fix this.

    kind regards

    #2676

    vorticism
    Participant

    This was my personal issue.
    It was api communication trouble according to wordfence setting.

    #2690

    alexg
    Keymaster

    Thank you for reporting this!

    I have since added the information about Wordfence to the troubleshooting guide for the CoinPayments adapter.

    #2693

    mc_deimon
    Participant

    Hi Vorticism,

    Can you tell me how you fixed the problem? I also use wordfence and it is to know how to configure it.

    Thank you very much.

    #2694

    vorticism
    Participant

    Helo, mc_deimon

    At first I thought it was a ‘country block’. I have blocked all countries except Korea for security.
    I disabled wordfence and the problem was solved.
    But I activate wordfence and turn off the country block, but still there is a problem with coin deposit.
    I’m still testing it for resolution.
    If I find a solution, I’ll share it.

    #2695

    alexg
    Keymaster

    Hello,

    I cannot reproduce the issue you are reporting with the default settings for Wordfence. In my installation it does not block the API endpoint for the CoinPayments IPN.

    However here’s something you can try:

    1. Go to Admin → Wordfence → Firewall → Whitelisted URLs

    2. Enter the following:
    URL: /
    Param Type: query string
    Param Name: wallets-cp-ipn

    This should whitelist that request.

    Alternatively, use the firewall’s “learning mode” while performing a deposit and it should create a rule. Learning mode can be enabled under “Basic Firewall Options” → “Web Application Firewall Status”

    If you try this, can you please report here what you found?

    Thank you.

    #2721

    vorticism
    Participant

    This seems to be my own problem.
    I first activated the network.(core and extensions) Then I activated it on a single main site.
    The user’s address and balance remain the same.
    After moving from a multi to a single, but the deposit was not. The withdrawal could be done.

    I came back to multisite again yesterday.
    The deposit now works.

    #2724

    alexg
    Keymaster

    Thank you for reporting.

    This is usually an issue with one or more wallets on CoinPayments being temporarily down for maintenance.

    When you first reported an issue with Bytecoin I remember distinctly that the wallet was down for maintenance. Probably your transaction went through now that the wallet is back online.

    This is an unavoidable drawback of relying on a third-party service.

    kind regards

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.