Open extra topbar

Balance not showing up in profile

If you are new here, please see some information on how to ask for support. Thank you!

Balance not showing up in profile

dashed-slug.net Forums CoinPayments.net Coin Adapter extension support Balance not showing up in profile

This topic contains 8 replies, has 2 voices, and was last updated by  alexg 4 months, 2 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #5296

    Nayiem
    Participant

    Hi Alex,

    I’m experiencing the following issue.

    – IPN is working fine.
    – Balance shows up in Coinpayments and in the profile of the user.

    However, the balance does not show up using the shortcode.
    Check provided screenshots.

    Thanks in advance.

    Attachments:
    You must be logged in to view attached files.
    #5301

    Nayiem
    Participant

    By the way, I did read the manual.

    I had SuperPWA installed, this is removed now.
    The cache of the server has been clearned.
    IPN message has been resubmitted.

    But the balance is still now visible on the frontend.

    However, when trying to complete a payment during checkout, the system does notice the balance in the wallet of the user.

    #5310

    alexg
    Keymaster

    1. To be clear, was the IPN submitted successfully? If so, then resubmitting will make no difference.

    2. Since the balance is updated in the backend, the IPN must have already been submitted. You can check in Wallets -> Transactions to see if there is a deposit transaction. What is the status of the transaction? It should be “done”.

    3. If the problem persists, you could try the following: Update the parent plugin to the latest version 3.9.2. 2. Go to Wallets -> Frontend settings -> JSON API Settings and check Disable transients (debug). Visit the frontend again and see if the balance is updated. If there is no change, deactivate the option again, as it will make the plugin somewhat slower when checked.

    Please let me know. Thank you.

    with regards

    #5313

    Nayiem
    Participant

    Hi Alex,

    Still didnt change.
    But I did notice after updating from 3.9.1 to 3.9.2 , when visiting the frontend section of the wallet,

    It shows: No currencies are currently enabled.

    And after 5 seconds it shows the currency list. But still in the same format as before.

    By the way, the problem on firefox and chrome is even worse, it doesnt show any balance at all.
    It says that the currencies are disabled.

    Kind regards,

    Nayiem

    #5315

    Nayiem
    Participant

    I have refreshed the servercache and the frontend does display wallet balances right now.

    The only issue left is that it takes around 5-10 seconds before the balance shows up.
    But instead of displaying a loading message, you will see message that says that no currency has been enabled.
    Disable transients option has not been checked and doesnt make a difference.

    I can temporarily fix this in the editor by displaying a different message.
    But just so you know.

    #5316

    alexg
    Keymaster

    Thank you for your reply.

    I will address the other issue you mentioned about the “no coins” message. (If possible, please open a new thread for each new issue. It helps me keep track of issues.)

    About the cache, could you please tell me which server cache you have cleared? Most likely the same problem will happen again if you attempt another deposit. I must know which cache this is, so that I can add something to the code to automatically exclude the JSON API responses from being cached.

    thank you

    #5363

    Nayiem
    Participant

    This is what I did to remove this issue.

    – Remove SuperPVA
    – Install W3 Total cache
    – Exclude wallet page from being cached by Total Cache.
    – Clear browser history

    #5365

    alexg
    Keymaster

    Thank you.

    Based on your finings I will investigate, to figure out if the plugin can somehow warn the user ahead if this issue arises.

    One more question – did you use the static templates of the shortcodes? If so then it makes sense to exclude that page. If not, then I would expect the solution to be to exclude the JSON API from your cache.

    thanks again and happy holidays

    #5477

    alexg
    Keymaster

    In the latest version 3.9.3 the “No currencies” message is only shown if there are actually no currencies enabled. It is no longer shown while the data is still being loaded from the server.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.