I reply to all queries on the forums and via email, once per day, Monday to Friday (not weekends).

If you are new here, please see some information on how to ask for support. Thank you!

Reply To: I’m getting ready to replace my hacked up monero adapter with yours

dashed-slug.net Forums TurtleCoin Adapter extension support I’m getting ready to replace my hacked up monero adapter with yours Reply To: I’m getting ready to replace my hacked up monero adapter with yours



OK it’s great news to hear that you can use wallet-api with your blockchain! You brought up several points, let me address all of them:

mbstring is not a required PHP module, so it is not an issue if you don’t have it.

The wallet password is saved in a transient, so it’s not necessarily in the DB. Assuming your coin’s symbol is ARMS, the transient name is trtl-ARMS-settings-wallet-passphrase. You can check what the value is using wp-cli:

wp transient get trtl-ARMS-settings-wallet-passphrase

Where transients are stored depends on whether you have a server-side object cache installed. Some object caches store transients on their own memory rather than the DB, so this is why you should use wp-cli to check transients, not MySQL/phpMyAdmin.

To see exactly how the password is saved, see the function update_value_if_not_empty(). It’s hooked on the save pre_update_option_ filter for option trtl-ARMS-settings-wallet-passphrase. The function gets a value and if it’s not empty, it tries to save it in a transient. If the value of the option wallets_secrets_retain_minutes is 0 or empty, then the transient is saved forever. Otherwise it’s saved for however many minutes you’ve set secrets to be saved for.

I’m not sure why your daemon IP and port are not saved in your DB. They should be in trtl-ARMS-settings-daemon-ip and trtl-ARMS-settings-daemon-port respectively.

I also noticed that, according to your settings as shown in the screenshot, your coin symbol is “2acoin” not “ARMS”. How are you defining your coin? I have included 2acoin/ARMS as a default coin, so you shouldn’t have to use wallets_turtlecoin_adapter_filter at all. If you are using this filter, delete it. Your coin’s name is 2ACoin and its symbol is “ARMS”: https://www.coingecko.com/en/coins/2acoin

Hope this helps. Good luck. Please let me know what you found. I think you are looking at the wrong options in your DB (wallets-2acoin-* rather than wallets-ARMS-*).

with regards